8.х БП Ошибка обновления. Базовая Бухгалтерия 2.0 -> 3.0

Тема в разделе ""1С:Бухгалтерия БП"", создана пользователем XOlegator, 5 июн 2013.

  1. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    Закономерность не найдете
  2. Dilya
    Offline

    Dilya

    Регистрация:
    30 янв 2013
    Сообщения:
    22
    Симпатии:
    0
    Баллы:
    1
    Обновила базовую бухгалтерию (версия 48.7) на 3-ю (версия 21.14), а непроведенные документы по персонифицированному учету (Опись сведений АДВ-6 и Пачка документов СЗВ) не перенеслись с первого квартала 2013 года. Хотя вышло 6 предупреждений (их не читала :closedeyes: ) Возможно ли такое?
  3. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    Вполне
  4. users.v8.1c.ru
    Offline

    users.v8.1c.ru

    Регистрация:
    4 июл 2013
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    проблема при обновлении БП с 20 на 30, релизы конф самые последние, платформа самая свежая 8.3. После первого запуска в режиме предприятия выдает сообщение в журнале: При вызове обработчика обновления:
    "ОбменСообщениямиВнутренний.УстановитьКодЭтойКонечнойТочки()"
    произошла ошибка:
    "{ОбщийМодуль.ОбменСообщениямиВнутренний.Модуль(424)}: Ошибка при вызове метода контекста (ПолучитьОбъект)
    ЭтаКонечнаяТочка = ЭтотУзел().ПолучитьОбъект();
    по причине:
    При подписке ПослеОтправкиДанных на событие ПередЗаписью произошла ошибка. Обработчик события не найден.".
  5. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    Ориентируйтесь на платформу используемую в облаках, на данный момент рабочая платформа 8.2.18
  6. TopicStarter Overlay
    XOlegator
    Offline

    XOlegator

    Регистрация:
    4 июн 2013
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1

    Вложения:

  7. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    Просто поддержка 2.0 прекращается, вот они и подгонять начинают. Поддержка 2.0 будет закрыта 01.01.2014 года
  8. Dilya
    Offline

    Dilya

    Регистрация:
    30 янв 2013
    Сообщения:
    22
    Симпатии:
    0
    Баллы:
    1
    Доброго времени суток!
    Пытаюсь обновиться в Бухгалтерии предприятия ПРОФ, платформа 109-я, 2-я бухгалтерия версии 51.8 на 3.0.24.12. Выдает уже другую ошибку

    {ОбщийМодуль.ЗарплатаКадрыОбновлениеСПредыдущейРедакции.Модуль(2436)}: Ошибка при вызове метода контекста (Записать)
    ДокументОбъект.Записать(РежимЗаписиДокумента.Запись);
    по причине:
    Значение поля "Дата" не может быть пустой датой

    Не знаю, что и делать. У XOlegator ошибка исправилась. У меня пока нет. Буду ждать обновлений
  9. Dilya
    Offline

    Dilya

    Регистрация:
    30 янв 2013
    Сообщения:
    22
    Симпатии:
    0
    Баллы:
    1
    Выдает следующие ошибки
    1) Код вида характеристики не уникален:УдалитьНазначенияСвойствКатегорийОбъектов (00000000121)

    2) Код вида характеристики не уникален:УдалитьНазначенияСвойствКатегорийОбъектов (00000000122)

    3) Код справочника стал неуникальным: ПрочиеДоходыИРасходы (00009)

    4) Код справочника стал неуникальным: УдалитьТерриториальныеУсловия (МКС)

    5) Код справочника стал неуникальным: УдалитьТерриториальныеУсловия (РКС)

    Может кто-то знает как их исправить? Буду очень признательна. :sm_rose:
  10. 1cUserAndrew
    Online

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.948
    Симпатии:
    149
    Баллы:
    104
    Заходите в соответствующие справочники, планы видов характеристик, находите элементы с одинаковыми кодами и меняете один из них (чтобы не были одинаковыми).
  11. Dilya
    Offline

    Dilya

    Регистрация:
    30 янв 2013
    Сообщения:
    22
    Симпатии:
    0
    Баллы:
    1
    Обновляюсь на 25-ю версию. Немного другая ошибка. Вроде и тестирование выполняю.
    {ОбщийМодуль.ЗарплатаКадрыОбновлениеСПредыдущейРедакции.Модуль(2440)}: Ошибка при вызове метода контекста (Записать)
    ДокументОбъект.Записать(РежимЗаписиДокумента.Запись);
    по причине:
    Значение поля "Дата" не может быть пустой датой
  12. 1cUserAndrew
    Online

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.948
    Симпатии:
    149
    Баллы:
    104
    Думаю, тут поможет только отладка. Надо смотреть, что за документ программа не может записать. Очевидно, у этого документа не заполнена дата.
  13. klaus38
    Offline

    klaus38

    Регистрация:
    1 окт 2013
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте что за зверь такой помогите Обновляюсь с версии Бухгалтерия предприятия, редакция 2.0.(2,0,51,6) на 3.0 (3.0.24.9) Платформа 8.2 (8.2.18.96) Файловый вариант
    Вот такая ошибка:

    При вызове обработчика обновления:
    "ОбменСообщениямиВнутренний.УстановитьКодЭтойКонечнойТочки()"
    произошла ошибка:
    "{ОбщийМодуль.ОбменСообщениямиВнутренний.Модуль(424)}: Ошибка при вызове метода контекста (ПолучитьОбъект)
    ЭтаКонечнаяТочка = ЭтотУзел().ПолучитьОбъект();
    по причине:
    При подписке ПослеОтправкиДанных на событие ПередЗаписью произошла ошибка. Обработчик события не найден.".
  14. klaus38
    Offline

    klaus38

    Регистрация:
    1 окт 2013
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Спасибо всем! Решение следующее

    Надо взять из чистой тройки и ручками вписать следующие обработчики

    ПриПолученииДанныхОтПодчиненного = СтандартныеПодсистемыСервер.ПриПолученииДанныхОтПодчиненногоСобытие
    ПриПолученииДанныхОтГлавного = СтандартныеПодсистемыСервер.ПриПолученииДанныхОтГлавногоСобытие
    ПриОтправкеДанныхПодчиненному = СтандартныеПодсистемыСервер.ПриОтправкеДанныхПодчиненномуСобытие
    ПриОтправкеДанныхГлавному = СтандартныеПодсистемыСервер.ПриОтправкеДанныхГлавномуСобытие
    ПослеПолученияДанных = СтандартныеПодсистемыСервер.ПослеОтправкиДанных
    ПослеОтправкиДанных = СтандартныеПодсистемыСервер.ПослеПолученияДанных
  15. DMLangepas
    Offline

    DMLangepas Опытный в 1С

    Регистрация:
    26 апр 2012
    Сообщения:
    191
    Симпатии:
    1
    Баллы:
    29
    Простым решением, это взять другой дистрибьютив.
  16. ViktorK
    Offline

    ViktorK

    Регистрация:
    7 окт 2013
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте обновляюсь с версии Бухгалтерия предприятия, редакция 2.0.(2,0,51,8) на 3.0 (3.0.24.11) Платформа 8.2 (8.2.18.102) Файловый вариант
    Ошибка как у вас
    Подскажите пожалуйста куда вписать эти обработчики, в дистриб конфигурации я их не нашел.
  17. klaus38
    Offline

    klaus38

    Регистрация:
    1 окт 2013
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте. Извините что не ответил сразу. В режиме конфигуратора находите вкладку "подписки на события"
    http://s020.radikal....0abca72104a.jpg
    В окне свойства Обработчик находите соответствующий списку
    http://s001.radikal....bab0dbf7505.jpg
    Скорей всего вам понадобится все шесть обработчиков
    http://s018.radikal....07f7d1b1174.jpg
    В обработчиках "ПослеПолученияДанных" и "ПослеОтправкиДанных" надо будет вставить процедуры
    Для Обработчика ПослеОтправкиДанных это будет

    Код:
    Процедура ПослеОтправкиДанных(Источник, Отказ) Экспорт
    
    Если Источник.ДополнительныеСвойства.Свойство("Загрузка") Тогда
    Возврат;
    КонецЕсли;
    
    Если Источник.Метаданные().РаспределеннаяИнформационнаяБаза Тогда
    
    Если Источник.НомерОтправленного <> ОбщегоНазначения.ЗначениеРеквизитаОбъекта(Источник.Ссылка, "НомерОтправленного") Тогда
    
    Если ПланыОбмена.ГлавныйУзел() = Источник.Ссылка Тогда
    
    ОбработчикиСобытия = ОбщегоНазначения.ОбработчикиСлужебногоСобытия(
    "СтандартныеПодсистемы.БазоваяФункциональность\ПослеОтправкиДанныхГлавному");
    
    Для каждого Обработчик Из ОбработчикиСобытия Цикл
    Обработчик.Модуль.ПослеОтправкиДанныхГлавному(Источник, Отказ);
    КонецЦикла;
    
    Иначе
    
    ОбработчикиСобытия = ОбщегоНазначения.ОбработчикиСлужебногоСобытия(
    "СтандартныеПодсистемы.БазоваяФункциональность\ПослеОтправкиДанныхПодчиненному");
    
    Для каждого Обработчик Из ОбработчикиСобытия Цикл
    Обработчик.Модуль.ПослеОтправкиДанныхПодчиненному(Источник, Отказ);
    КонецЦикла;
    
    КонецЕсли;
    
    КонецЕсли;
    
    КонецЕсли;
    
    КонецПроцедуры
    


    Для Обработчика ПослеПолученияДанных это будет
    Код:
    Процедура ПослеПолученияДанных(Источник, Отказ) Экспорт
    
    Если Источник.ДополнительныеСвойства.Свойство("Загрузка") Тогда
    Возврат;
    КонецЕсли;
    
    Если Источник.Метаданные().РаспределеннаяИнформационнаяБаза Тогда
    
    Если Источник.НомерПринятого <> ОбщегоНазначения.ЗначениеРеквизитаОбъекта(Источник.Ссылка, "НомерПринятого") Тогда
    
    Если ПланыОбмена.ГлавныйУзел() = Источник.Ссылка Тогда
    
    ОбработчикиСобытия = ОбщегоНазначения.ОбработчикиСлужебногоСобытия(
    "СтандартныеПодсистемы.БазоваяФункциональность\ПослеПолученияДанныхОтГлавного");
    
    Для каждого Обработчик Из ОбработчикиСобытия Цикл
    Обработчик.Модуль.ПослеПолученияДанныхОтГлавного(Источник, Отказ);
    КонецЦикла;
    
    Иначе
    ОбработчикиСобытия = ОбщегоНазначения.ОбработчикиСлужебногоСобытия(
    "СтандартныеПодсистемы.БазоваяФункциональность\ПослеПолученияДанныхОтПодчиненного");
    
    Для каждого Обработчик Из ОбработчикиСобытия Цикл
    Обработчик.Модуль.ПослеПолученияДанныхОтПодчиненного(Источник, Отказ);
    КонецЦикла;
    
    КонецЕсли;
    
    КонецЕсли;
    
    КонецЕсли;
    
    КонецПроцедуры
    


    Соответственно это для полностью или частично снятой с поддержки. по сути это крайние меры мне никто из гуру не ответил пришлось выкручиваться самому. Надеюсь что я вам помог!
    P.S. Модуль и строка куда вписывать код у вас после того как вы выберите обработчик откроется сам
  18. Dilya
    Offline

    Dilya

    Регистрация:
    30 янв 2013
    Сообщения:
    22
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте. Опять обновляюсь с 53.4 версии на 3.0.26.6 снова та же ошибка.

    {ОбщийМодуль.ЗарплатаКадрыОбновлениеСПредыдущейРедакции.Модуль(2445)}: Ошибка при вызове метода контекста (Записать)
    ДокументОбъект.Записать(РежимЗаписиДокумента.Запись);
    по причине:
    Значение поля "Дата" не может быть пустой датой.

    Может как-нибудь поправят. Потому что в плане видов характеристик ничего поправить не удается. Надо снимать с поддержки. Этого не хотелось бы.

    Вообще-то есть и другой метод перехода на тройку. Более простой. Взять и перенести остатки с 2013 года на 2014, а также справочники. Тогда уж точно не будет никаких ошибок.
  19. rerix
    Offline

    rerix

    Регистрация:
    6 янв 2014
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    помогите с переходом Бухгалтерии предприятия 2_0_54_9 на 3_0_28_7. Технологическая платформа 8.3 Версия 8.3.4.365.
    Все сделал по инструкции в конфигураторе.
    после запуска предприятия пишет: "при обновлении версии программы: Метод объекта не обнаружен (Движения)"

    При вызове обработчика обновления:
    "ЗарплатаКадрыОбновлениеСПредыдущейРедакции.ЗарплатаКадрыОбновлениеС20()"
    произошла ошибка:
    "{ОбщийМодуль.ЗарплатаКадрыОбновлениеСПредыдущейРедакции.Модуль(11815)}: Метод объекта не обнаружен (Движения)
    Или Не НовыйРегистратор.Метаданные().Движения().Содержит(Метаданные.РегистрыНакопления[ИмяРегистра]) Тогда".

    как быть... помогите!!!!
  20. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    В Вашем случае неудачно выбраны конфигурации для перехода. Скорее всего в 3.0 опять не адаптирован переход. Нужно уточнять с какого релиза переход выполняется на данный момент.

Поделиться этой страницей