8.х ОБМЕН Ошибка "Недостаточно памяти" при обмене

Тема в разделе "Обмен данными в "1С:Предприятие 8"", создана пользователем FateevR, 15 янв 2009.

  1. TopicStarter Overlay
    FateevR
    Offline

    FateevR

    Регистрация:
    15 янв 2009
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Доброе время суток!
    Коллеги, помогите! Есть загрузка данных из БП в УПП. Загрузка идет сразу в базу (это не критично, можно и в файл). Загрузка идет через обработку "Универсальный обмен данными XML". План обмена делался в последней конвертации (если это последняя, Конвертация данных, редакция 2.0 (2.0.24.1)). При загрузке документа "Корректировка долга" вылетает ошибка "Недостаточно памяти", там много проводок. Как обойти такую проблему? 1С сервер перезагружался, процесс во время загрузки занимает 380 метров в оперативке. Я пытался попробовать галочку в конвертации "ВыгружатьГруппуЧерезФайл" - выдает уже ошибку в самой обработке обмена, при чем на этапе начала загрузки проводок (грузил в файл, так как сразу в базу эта галочка не работает).
    Пробовал загрузить этот документ универсальной обработкой "ВыгрузкаЗагрузкаДанныхXML.epf" (конфигурация в части метаданных по этому документу и ссылкам в этом документе одинаковая) - выдает какую-то ошибку в XML, пробовал даже через файл *.fi грузить - показывает в отладчике вместо документа с проводками 1 объект узла обмена и больше ничего не грузит.
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Как-то было у меня такое - дело было срочное, и я на коленке написал перенос через OLE :)
  3. TopicStarter Overlay
    FateevR
    Offline

    FateevR

    Регистрация:
    15 янв 2009
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    спасибо за ответ
  4. TopicStarter Overlay
    FateevR
    Offline

    FateevR

    Регистрация:
    15 янв 2009
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Докопался :)
    в общем, в стандартной обработке "Универсальный обмен данными" в процедуре "Выгрузить группу свойств" вместо
    Код:
    Если ПКГС.НуженУзелXMLПриВыгрузке Тогда
    ДобавитьПодчиненный(УзелКоллекцииОбъектов, УзелОбъектаКоллекции);
    Иначе
    УзелКоллекцииОбъектов.ЗаписатьКонецЭлемента();
    КонецЕсли;		
    // заполням файл объектами узла
    Если ВыгружатьГруппуЧерезФайл Тогда
    
    УзелОбъектаКоллекции.ЗаписатьКонецЭлемента();
    ИнформацияДляЗаписиВФайл = УзелОбъектаКоллекции.Закрыть();
    ВременныйФайЗаписей.ЗаписатьСтроку(ИнформацияДляЗаписиВФайл);
    
    КонецЕсли;
    
    
    пишем так

    Код:
    	Если ПКГС.НуженУзелXMLПриВыгрузке Тогда
    ДобавитьПодчиненный(УзелКоллекцииОбъектов, УзелОбъектаКоллекции);
    ИначеЕсли ВыгружатьГруппуЧерезФайл Тогда
    УзелОбъектаКоллекции.ЗаписатьКонецЭлемента();
    ИнформацияДляЗаписиВФайл = УзелОбъектаКоллекции.Закрыть();
    ВременныйФайЗаписей.ЗаписатьСтроку(ИнформацияДляЗаписиВФайл);
    Иначе
    УзелКоллекцииОбъектов.ЗаписатьКонецЭлемента();
    КонецЕсли;		
    
    
    и все чудненько грузится в файл без ошибки памяти

    Не забываем про тег
    Код:
    ! (lazy)[/b][/color]

Поделиться этой страницей