7.7 Ошибка Модуль Документа(707)}: Ожидается ключевое слово 'КонецПроцедуры'

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем Delion, 26 июн 2013.

  1. TopicStarter Overlay
    Delion
    Offline

    Delion Опытный в 1С

    Регистрация:
    18 июл 2012
    Сообщения:
    63
    Симпатии:
    0
    Баллы:
    26
    При проводке ряда документов выдает ошибку:

    <<?>>КонецЕсли;
    {Документ.ОказаниеУслуг.Модуль Документа(707)}: Ожидается ключевое слово 'КонецПроцедуры' ('EndProcedure')
    <<?>>КонецЕсли;
    {Документ.ОказаниеУслуг.Модуль Документа(707)}: Ожидается ключевое слово 'КонецПроцедуры' ('EndProcedure')
  2. GlukAl
    Offline

    GlukAl Опытный в 1С

    Регистрация:
    4 окт 2012
    Сообщения:
    187
    Симпатии:
    7
    Баллы:
    29
    очевидно что не совпадает количество отработанных ЕСЛИ и КОНЕЦЕСЛИ
    нужна вся процедура для анализа
  3. TopicStarter Overlay
    Delion
    Offline

    Delion Опытный в 1С

    Регистрация:
    18 июл 2012
    Сообщения:
    63
    Симпатии:
    0
    Баллы:
    26
    Как мне всю процедуру вам предоставить для анализа? (в смысле, что мне нужно сделать)
  4. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Нужно найти того человека, что вносил изменения в код, настучать ему по рукам и заставить все вернуть обратно.... Не известно, какие еще проблемы там с документами могут быть
  5. TopicStarter Overlay
    Delion
    Offline

    Delion Опытный в 1С

    Регистрация:
    18 июл 2012
    Сообщения:
    63
    Симпатии:
    0
    Баллы:
    26
    Так нет такого человека :) Никто ничего такого не делал. Это скорее всего связано с проблемой совместного доступа к базе и в следствии с ошибками которые возникают в процессе работы..
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Нет. Это явное рукоблудство. При ошибках доступа 1с молча отваливается или выскакивает иная ошибка. У вас же явная ошибка программиста. Убедитесь - запустите в конфигураторе полный синтаксический контроль
  7. TopicStarter Overlay
    Delion
    Offline

    Delion Опытный в 1С

    Регистрация:
    18 июл 2012
    Сообщения:
    63
    Симпатии:
    0
    Баллы:
    26
    Операция.Дебет.РасходыБудущихПериодов = РБП<<?>>("Отчисления в фонды");
    {Документ.ОтчисленияВФонды.Модуль Документа(335)}: Функция не обнаружена (РБП)
    Операция.Дебет.НакладныеРасходы = НР<<?>>("Отчисления на соцнужды от ЗП АХП");
    {Документ.ОтчисленияВФонды.Модуль Документа(399)}: Функция не обнаружена (НР)
    Операция.Дебет.СтатьиЗатратНаПроизводство = СтатьиЗатрат2<<?>>("Отчисления в фонды от ЗП рабочих");
    {Документ.ОтчисленияВФонды.Модуль Документа(467)}: Функция не обнаружена (СтатьиЗатрат2)
    Операция.Дебет.СтатьиЗатратНаПроизводство = СтатьиЗатрат2<<?>>("Отчисления в фонды от ЗП рабочих");
    {Документ.ОтчисленияВФонды.Модуль Документа(533)}: Функция не обнаружена (СтатьиЗатрат2)
    Операция.Дебет.СтатьиЭСММ = СтатьиЭСММ<<?>>("Отчисления в фонды от ЗП рабочих");
    {Документ.ОтчисленияВФонды.Модуль Документа(587)}: Функция не обнаружена (СтатьиЭСММ)
    Операция.Дебет.СтатьиЗатратНаПроизводство = СтатьиЗатрат2<<?>>("Отчисления в фонды от ЗП рабочих");
    {Документ.ОтчисленияВФонды.Модуль Документа(641)}: Функция не обнаружена (СтатьиЗатрат2)
    Операция.Дебет.СтатьиЗатратНаПроизводство = СтатьиЗатрат2<<?>>("Отчисления в фонды от ЗП рабочих");
    {Документ.ОтчисленияВФонды.Модуль Документа(710)}: Функция не обнаружена (СтатьиЗатрат2)
    Операция.Дебет.СтатьиЗатратНаПроизводство = СтатьиЗатрат2<<?>>("Отчисления в фонды от ЗП рабочих");
    {Документ.ОтчисленияВФонды.Модуль Документа(776)}: Функция не обнаружена (СтатьиЗатрат2)
    <<?>>КонецЕсли;
    {Документ.ОказаниеУслуг.Модуль Документа(707)}: Ожидается ключевое слово 'КонецПроцедуры' ('EndProcedure')
    <<?>>КонецЕсли;
    {Документ.ОказаниеУслуг.Модуль Документа(707)}: Ожидается ключевое слово 'КонецПроцедуры' ('EndProcedure')
    Возврат ГлВариантРеализации<<?>>(ТипРеализации, СтавкаНДС, СтавкаНГСМ, СтавкаНП);
    {Обработка.ЗагрузкаПроводок.Форма.Модуль(62)}: Функция не обнаружена (ГлВариантРеализации)
    Субконто = ГлОтложенныйНалог<<?>>("НДС");
    {Обработка.ЗагрузкаПроводок.Форма.Модуль(345)}: Функция не обнаружена (ГлОтложенныйНалог)
    Субконто = ГлОтложенныйНалог<<?>>("НДС");
    {Обработка.ЗагрузкаПроводок.Форма.Модуль(388)}: Функция не обнаружена (ГлОтложенныйНалог)
    Если глПланСчетов<<?>>()=1 Тогда // по старому плану счетов
    {Обработка.РегламентированныеОтчетыССайта.Форма.Модуль(174)}: Функция не обнаружена (глПланСчетов)
    Если глПланСчетов<<?>>()=1 Тогда
    {Обработка.РегламентированныеОтчетыССайта.Форма.Модуль(190)}: Функция не обнаружена (глПланСчетов)
    Если глПланСчетов<<?>>()=1 Тогда
    {Обработка.ПроверкаОбновлений.Форма.Модуль(45)}: Функция не обнаружена (глПланСчетов)
    При проверке модуля обнаружены синтаксические ошибки!


    Ошибок много. А каким образом такие ошибки появляются? 1C не обновляется, конфигурированием и программированием никто не занимается. Просто 2 пользователя работают с ней постоянно и все..
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    какой номер релиза конфигурации?
  9. TopicStarter Overlay
    Delion
    Offline

    Delion Опытный в 1С

    Регистрация:
    18 июл 2012
    Сообщения:
    63
    Симпатии:
    0
    Баллы:
    26
    1C: Подрядчик строительства 2.3 Релиз: 7.70.2384
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    конфа уже давным давно снята с поддержки. Архивы БД есть?
  11. TopicStarter Overlay
    Delion
    Offline

    Delion Опытный в 1С

    Регистрация:
    18 июл 2012
    Сообщения:
    63
    Симпатии:
    0
    Баллы:
    26
    Архивы есть.
  12. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    нужно сравнить МДшники. Рабочий и из архива.
  13. TopicStarter Overlay
    Delion
    Offline

    Delion Опытный в 1С

    Регистрация:
    18 июл 2012
    Сообщения:
    63
    Симпатии:
    0
    Баллы:
    26
    Архивы делаются каждый день наверное уже 10 месяцев, (раньше я не работал и архивы не делались)

    Каким образом их нужно будет сравнить?
  14. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Конфа кажется уже давно снята с поддержки. Так что обновлений быть не может.
    1) Возьмите из архива файл 1cv7.md
    2) Конфигуратор - Меню - Администрирование - Сохранить БД. (копия)
    3) Конфигуратор - Меню - Конфигурация - Объединение конфигураций. Выберите файл из архива. 1с покажет отличия
  15. TopicStarter Overlay
    Delion
    Offline

    Delion Опытный в 1С

    Регистрация:
    18 июл 2012
    Сообщения:
    63
    Симпатии:
    0
    Баллы:
    26
    Сделал сравнение МДшников. Единственное отличие в релизе конфигурации был 7.70.2376, а стал 7.70.2384.

    Есть у нас контора которой платят деньги за обслуживание, но фактически ничего не делается кроме консультаций главного бухгалтера по телефону, в случае каких либо проблем с 1С они всегда говорят мы можем прислать специалиста, но за дополнительную плату. Отказаться от них никак, точнее я много для этого сделал, но позиции главбуха сильны, хотя в принципе деньги не мои, так что особо все равно.

    09 июня (воскресенье) я поставил новый компьютер главному бухгалтеру (а до этого были проблемы с совместным доступом при установленном KAV), до 17 июня проблем не было, 18 июня контора нас обслуживающая произвела обновление конфигурации, но мне никто не сообщил об этом (я не постоянно там нахожусь), после этого на этой же неделе начались проблемы с запуском и открытием файлов, а также с аварийным завершением работы 1С.

    Я все не мог понять почему так резко начались проблемы, и вот 26 июня начались ошибки с проводкой документов и ошибка 707. Сделав полный синтаксический контроль баз данных за каждый день июня месяца и сравнение mdшников было обнаружено что 18 июня было произведено обновление релиза и соотвественно ошибка 707 появилась после обновления релиза.

    Это можно как-то самим исправить (ну или напрячь контору нас обслуживающую) или главбух и экономист попали на переделывание всей своей работы с 18 июня и по сегодняшний день (как наказание для них было бы справедливо)?
  16. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    Мне кажется, тут все просто. Криво сделано обновление. По идее, ваших обслуживальшиков гнать надо поганой метлой. Но, если их, по вашему утверждению, позиции сильны, благодаря "крышеванию" главбуха, то вот пусть главбух и расхлебывает.
    По тексту ошибок, любой более-менее грамотный спец вам скажет, что конфа была переделана, а потом криво обновлена. Более детально вам сможет сказать только нормальный спец, видя конфу перед глазами.
  17. TopicStarter Overlay
    Delion
    Offline

    Delion Опытный в 1С

    Регистрация:
    18 июл 2012
    Сообщения:
    63
    Симпатии:
    0
    Баллы:
    26
    В понедельник буду звонить и пусть они решают вопрос с исправлением ошибок. Я правда договор с ними не видел, знаю что мы сидим на подписке+обслуживании, но по идее все обнаруженные при синтаксическом контроле ошибки они и должны исправить?
  18. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Обновление вам делал варвар. Он даже не сделал элементарного - проверку своей работы (полный синтаксический контроль). Надеюсь сделана копия на момент обновления.
  19. TopicStarter Overlay
    Delion
    Offline

    Delion Опытный в 1С

    Регистрация:
    18 июл 2012
    Сообщения:
    63
    Симпатии:
    0
    Баллы:
    26
    Копия есть., но 10 дней работы бухгалтера и экономиста в пустую, правда это исключительно их проблема...
  20. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    >Единственное отличие в релизе конфигурации был 7.70.2376, а стал 7.70.2384.
    Не верю. Если б так было, то и ошибки б не было
    выкладывай мд и мд из копии (только в архив засунь)

Поделиться этой страницей