8.х Ошибка чтения значения

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Gulf_Stream, 24 дек 2010.

  1. TopicStarter Overlay
    Gulf_Stream
    Offline

    Gulf_Stream Опытный в 1С

    Регистрация:
    4 янв 2009
    Сообщения:
    71
    Симпатии:
    0
    Баллы:
    26
    Добрый день!
    Столкнулся с такой проблемой, при выполнении любой выборки из оборотного регистра накопления
    отладчик выдаёт во всех полях "Ошибка чтения значения". При этом консоль запросов работает нормально, и выдаёт нужные значения.
    На всякий случай привожу текст запроса:

    Код:
    ВЫБРАТЬ 
    |	ПродажиПоАкциямОбороты.ЧекККМ,
    |	ПродажиПоАкциямОбороты.ДатаЧека,
    |	ПродажиПоАкциямОбороты.Номенклатура,
    |	ПродажиПоАкциямОбороты.Условие,
    |	ПродажиПоАкциямОбороты.ЗначениеУсловия,
    |	ПродажиПоАкциямОбороты.КоличествоОборот,
    |	ПродажиПоАкциямОбороты.СуммаОборот
    |ИЗ
    |	РегистрНакопления.ПродажиПоАкциям.Обороты КАК ПродажиПоАкциямОбороты
    
    Запрос делался конструктором и ошибиться тут не где.
    Используется локальная база, пользователь с полными правами. На регистр всем ролям даны все права.
    Уже не знаю что и думать, подскажите пожалуста =)
  2. TopicStarter Overlay
    Gulf_Stream
    Offline

    Gulf_Stream Опытный в 1С

    Регистрация:
    4 янв 2009
    Сообщения:
    71
    Симпатии:
    0
    Баллы:
    26
    Причём этот глюк только в режиме отладки, если запускать преприятие отдельно (а не из конфигуратора по F5) то всё работает.
  3. r-d-v2008
    Offline

    r-d-v2008 Опытный в 1С

    Регистрация:
    16 сен 2010
    Сообщения:
    272
    Симпатии:
    0
    Баллы:
    26
    протестите базу
  4. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.771
    Симпатии:
    509
    Баллы:
    204
    Обороты это виртуальная таблица, и мне кажется все из-за этого. Сильно не пинайте, это мое предположение.
  5. Itsys
    Offline

    Itsys Опытный в 1С

    Регистрация:
    3 янв 2010
    Сообщения:
    1.394
    Симпатии:
    0
    Баллы:
    26
    Видится всего 2 варианта: Запрет через RLS и глюк в базе. Если второе, попробуйте почистить кеш.
  6. TopicStarter Overlay
    Gulf_Stream
    Offline

    Gulf_Stream Опытный в 1С

    Регистрация:
    4 янв 2009
    Сообщения:
    71
    Симпатии:
    0
    Баллы:
    26
    Видимо был глюк в базе, тестирование и исправление + перезагрузка решили проблему. Спасибо за ответы.
  7. Леркин
    Offline

    Леркин

    Регистрация:
    21 ноя 2014
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Ребят, помогите пожалуйста. та же проблема. Мне кажется что-то накрутила с свыводом


    Код:
    Процедура ОсновныеДействияОК(Кнопка)
    Форма = Обработки.ПланированиеПроизводства.ПолучитьФорму(,"Владелец");
    ТаблицаОбработки = Форма.ПродукцияВПлантровании.Выгрузить();
    ////ЗАКАЗ ПОКУПАТЕЛЯ /////
    Текст = "ВЫБРАТЬ
    | ЗаказПокупателяТовары.Ссылка
    |ПОМЕСТИТЬ ВременнаяТаблица
    |ИЗ
    | Документ.ЗаказПокупателя КАК ЗаказПокупателяТовары
    |ГДЕ
    | ЗаказПокупателяТовары.Дата < &период2
    |;
    |
    |////////////////////////////////////////////////////////////////////////////////
    |ВЫБРАТЬ РАЗЛИЧНЫЕ
    | ЗаказПокупателя.ДатаОтгрузки КАК ДатаОтгрузки,
    | ЗаказПокупателя.Номер,
    | ЗаказПокупателя.РегионДоставки КАК Направление,
    | ЗаказПокупателя.ОтветственныйЗКДОР,
    | ВЫРАЗИТЬ(ЗаказПокупателя.КомментарийДляПроизводства КАК СТРОКА(100)) КАК КомментарийДляПроизводства,
    | ЗаказПокупателя.Ссылка КАК Ссылка
    |ИЗ
    | ВременнаяТаблица КАК ВременнаяТаблица
    | ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЗаказПокупателя КАК ЗаказПокупателя
    | ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЗаказПокупателя.Товары КАК ЗаказПокупателяТовары
    | ПО ЗаказПокупателя.Ссылка = ЗаказПокупателяТовары.Ссылка
    | ПО ВременнаяТаблица.Ссылка = ЗаказПокупателя.Ссылка
    |ГДЕ
    | (НЕ (ВЫРАЗИТЬ(ЗаказПокупателя.КомментарийДляПроизводства КАК СТРОКА(100))) = """")
    | И ЗаказПокупателя.ДатаОтгрузки МЕЖДУ &Период1 И &Период2
    |
    |ОБЪЕДИНИТЬ
    |
    |ВЫБРАТЬ
    | 0,
    | 0,
    | ВЫРАЗИТЬ(ЗаказПокупателяТовары.КоличествоЛистовНаПоддоне КАК СТРОКА(100)) КАК Комментарий,
    | ЗаказПокупателяТовары.Номенклатура КАК Номенклатура,
    | ЗаказПокупателяТовары.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры,
    | ЗаказПокупателяТовары.Ссылка
    |ИЗ
    | ВременнаяТаблица КАК ВременнаяТаблица
    | ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЗаказПокупателя КАК ЗаказПокупателя
    | ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЗаказПокупателя.Товары КАК ЗаказПокупателяТовары
    | ПО ЗаказПокупателя.Ссылка = ЗаказПокупателяТовары.Ссылка
    | ПО ВременнаяТаблица.Ссылка = ЗаказПокупателя.Ссылка
    |ГДЕ
    | (НЕ (ВЫРАЗИТЬ(ЗаказПокупателяТовары.КоличествоЛистовНаПоддоне КАК СТРОКА(100))) = """")
    | И ЗаказПокупателя.ДатаОтгрузки МЕЖДУ &Период1 И &Период2
    |
    |УПОРЯДОЧИТЬ ПО
    | ДатаОтгрузки УБЫВ
    |ИТОГИ ПО
    | Ссылка";
    Запрос = Новый Запрос;
    //Запрос.УстановитьПараметр("ВременнаяТаблица", ТаблицаОбработки);
    Запрос.УстановитьПараметр("период1", ЭлементыФормы.период1.Значение);
    Запрос.УстановитьПараметр("период2", ЭлементыФормы.период2.Значение);
    Запрос.Текст = Текст;
    РезультатЗапроса = Запрос.Выполнить();
    Результат = РезультатЗапроса.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам );
    // СОЗДАНИЕ НОВОГО ТАБЛИЧНОГО ДОКУМЕНТА
    ТабДок = Новый ТабличныйДокумент;
    Макет = Обработки.ПланированиеПроизводства.ПолучитьМакет("Комментарии");
    //Шапка
    ОбластьШапки = Макет.ПолучитьОбласть("Шапка");
    ТабДок.Вывести(ОбластьШапки);
    к=1;
    Пока Результат.Следующий() Цикл
    //Данные ВНЕШНИЕ
    ОбластьДанныеГруппировки = Макет.ПолучитьОбласть("ДанныеГруппировки");
    ОбластьДанныеГруппировки.Параметры.НПП = к;
    ОбластьДанныеГруппировки.Параметры.ДатаОтгрузки = Результат.ДатаОтгрузки;
    ОбластьДанныеГруппировки.Параметры.НомерЗаказа = Результат.Номер;
    ОбластьДанныеГруппировки.Параметры.Направление = Результат.Направление;
    ОбластьДанныеГруппировки.Параметры.Ответственный = Результат.ОтветственныйЗКДОР;
    ОбластьДанныеГруппировки.Параметры.ОбщийКомментарий = Результат.КомментарийДляПроизводства;
    ТабДок.Вывести(ОбластьДанныеГруппировки);
    Результат1 = Результат.Выбрать().Следующий();
    м=1;
    //Данные ВНУТРЕННИЕ
    Пока Результат1.Следующий() Цикл
    Если Результат1.Ссылка=Результат.Ссылка Тогда
    ОбластьДанные = Макет.ПолучитьОбласть("Данные");
    ОбластьДанные.Параметры.Номер = м;
    ОбластьДанные.Параметры.Номенклатура = Результат1.Номенклатура;
    ОбластьДанные.Параметры.ХарактеристикаНоменклатуры = Результат1.ХарактеристикаНоменклатуры;
    ОбластьДанные.Параметры.Комментарий = Результат1.Комментарий;
    ТабДок.Вывести(ОбластьДанные);
    Иначе
    Продолжить;
    КонецЕсли;
    м=м+1;
    КонецЦикла;
    к=к+1;
    КонецЦикла;
    ТабДок.ОтображатьСетку = Ложь;
    ТабДок.Защита = Истина;
    ТабДок.Показать();
    Последнее редактирование модератором: 21 ноя 2014
Похожие темы
  1. Adminspb
    Ответов:
    1
    Просмотров:
    1.183
  2. Lokky
    Ответов:
    11
    Просмотров:
    7.297
  3. materiy_boec
    Ответов:
    0
    Просмотров:
    1.047
  4. ВасилийХаймоев
    Ответов:
    2
    Просмотров:
    688
  5. maximsobaka
    Ответов:
    22
    Просмотров:
    487
Загрузка...

Поделиться этой страницей