8.х БП Ошибка 2-НДФЛ 1С 8.0

Тема в разделе ""1С:Бухгалтерия БП"", создана пользователем Malak, 24 мар 2008.

  1. TopicStarter Overlay
    Malak
    Offline

    Malak

    Регистрация:
    24 мар 2008
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте!

    Установлена 1С 8.0 Базовая редакция, обновление 1.5.22.3

    При выгрузке файла 2-НДФЛ по шести сотрудникам выдает ошибку по одному и тому же сотруднику: "Номер справки должен состоять из 6 символов".

    Подскажите, в чем проблема?

    Спасибо!
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Ну так, собственно, он и пишет, в чем дело :)
  3. TopicStarter Overlay
    Malak
    Offline

    Malak

    Регистрация:
    24 мар 2008
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Остроумно! :)

    Но по остальным работникам все выгружается, если удалить проблемного сотрудника из списка и сделать выгрузку форм 2-НДФЛ в файл.
    Где искать ошибку? Почему программа ругается на номер справки?
  4. TopicStarter Overlay
    Malak
    Offline

    Malak

    Регистрация:
    24 мар 2008
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Народ!

    Я что, какой-то суперсложный вопрос задал? Вроде сайт поддержки. Может кто-нибудь кроме BabySG, дать конкретно наводку на то, как исправить ошибку с номером справки?
    По остальным сотрудникам же все выгружается, а когда добавляешь "проблемного", то на него программа жалуется. Хотя по всем сотрудникам данные все заполнены одинаково.

    Спасибо.
  5. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Собственно, если пишет подробно, в чем дело, трудно объяснить, в чем дело :)
  6. TopicStarter Overlay
    Malak
    Offline

    Malak

    Регистрация:
    24 мар 2008
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Ну вот, глубокоуважаемый(ая), BabyS, объясните мне где этот номер из 6 символов воткнуть. :) Можно с картинками. ;)
  7. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29

    Вложения:

    • 2ндфл.png
      2ндфл.png
      Размер файла:
      36 КБ
      Просмотров:
      143
  8. TopicStarter Overlay
    Malak
    Offline

    Malak

    Регистрация:
    24 мар 2008
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Приветствую, BabySG!

    Ну вы совсем меня за... считаете! :)))
    Там есть функция - пронумеровать. Это раз!
    По остальным сотрудникам все нормально, а по одному, не хочет принимать тот номер, который программа присвоила.
    Даже если вручную изменить номер данного сотружника или всех, то результат тот же. Ругается только на того же сотрудника.

    Просто у меня подозрение, что может после обновления у меня такой трабл случился (обновлял с ранней версии 8.0) или все же что-то по сотруднику недозаполнил, а программа ругается на номер справки.

    О как!
  9. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Приведите ТОЧНОЕ сообщение об ошибке, ибо в 1.6.5.4 такой ошибки нет.
    Вот код:
    Код:
    Если Не ЗначениеЗаполнено(ВыборкаПоРаботникиОрганизации.ФизЛицо) Тогда
    ОбщегоНазначения.ОшибкаПриПроведении(НачалоСообщения + "не указано физическое лицо!", Отказ, Заголовок);
    ИначеЕсли ВыборкаПоРаботникиОрганизации.ЕстьПовторяющиесяСправки Тогда
    ОбщегоНазначения.ОшибкаПриПроведении(НачалоСообщения + "справка повторяется в другой строке документа (" + 
    ВыборкаПоРаботникиОрганизации.НомерСтрокиПовторяющейсяСправки + ")!", Отказ, Заголовок);
    КонецЕсли;
    
    Если Не ЗначениеЗаполнено(ВыборкаПоРаботникиОрганизации.НомерСправки) Тогда
    ОбщегоНазначения.ОшибкаПриПроведении(НачалоСообщения + "не указан номер справки!", Отказ, Заголовок);
    ИначеЕсли ВыборкаПоРаботникиОрганизации.ЕстьПовторяющиесяНомераСправок Тогда
    ОбщегоНазначения.ОшибкаПриПроведении(НачалоСообщения + "номер справки повторяется в другой строке документа (" + 
    ВыборкаПоРаботникиОрганизации.НомерСтрокиПовторяющегосяНомераСправки + ")!", Отказ, Заголовок);
    КонецЕсли;
    
    Если ВыборкаПоШапкеДокумента.ПроверятьСтавку Тогда
    Если Не ЗначениеЗаполнено(ВыборкаПоРаботникиОрганизации.Ставка) Тогда
    ОбщегоНазначения.ОшибкаПриПроведении(НачалоСообщения + 
    "не указана ставка налогообложения дохода!", Отказ, Заголовок);
    КонецЕсли;
    КонецЕсли;
    
    Если ВыборкаПоШапкеДокумента.ПроверятьКоды Тогда
    Если Не ЗначениеЗаполнено(ВыборкаПоРаботникиОрганизации.КодПоОКАТО) Тогда
    ОбщегоНазначения.ОшибкаПриПроведении(НачалоСообщения + "не указан код по ОКАТО!", Отказ, Заголовок);
    ИначеЕсли СтрДлина(СокрЛП(ВыборкаПоРаботникиОрганизации.КодПоОКАТО)) <> 11 Тогда
    ОбщегоНазначения.ОшибкаПриПроведении(НачалоСообщения + "неверно указан код по ОКАТО!", Отказ, Заголовок);
    КонецЕсли;
    Если Не ЗначениеЗаполнено(ВыборкаПоРаботникиОрганизации.КПП) Тогда
    ОбщегоНазначения.ОшибкаПриПроведении(НачалоСообщения + "не указан КПП!", Отказ, Заголовок);
    ИначеЕсли СтрДлина(СокрЛП(ВыборкаПоРаботникиОрганизации.КПП)) <> 9 Тогда
    ОбщегоНазначения.ОшибкаПриПроведении(НачалоСообщения + "неверно указан КПП!", Отказ, Заголовок);
    КонецЕсли;
    КонецЕсли;
    
    
  10. TopicStarter Overlay
    Malak
    Offline

    Malak

    Регистрация:
    24 мар 2008
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Установлена версия 1.5.22.3

    Тему можно закрыть. Вызвали программиста. Меня не было, не знаю что сделал, но все исправил. Как передал нашим дамам..."Какой-то конфликт и что-то неправильно обрабатывалось. Скорей всего из-за криво установленных обновлении.". Думаю, дамам более развернутого ответа и не нужно было. :)

    Спасибо за помощь!

Поделиться этой страницей