7.7 Оптимизация построения отчета.

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем AlexFF, 15 мар 2007.

  1. TopicStarter Overlay
    AlexFF
    Offline

    AlexFF Разбирающийся

    Регистрация:
    6 мар 2007
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    26
    Конфигурация Торговля и Склад ред. 9.2 (7.70.938)
    Задача: В отчете необходимо отобразить последний документ по которому на склад поступил товар и в каком количестве.

    По определению на склад товар поступает от поставщика, при возврате от покупателе и при перемещении между складами. С нахождением документа проблем нет а вот с количеством..... Делую это тупым перебором строк документа. А в поступлении бывает до 500 строк. Можно как-то оптимизировать этот процесс. При построении отчета за большой период, отчета приходиться ждать очень долго. Вот мой код:

    Если Найти(Рег.ТекущийДокумент(), "Поступление") > 0 Тогда
    ДокумП.НайтиДокумент(Рег.ТекущийДокумент());
    Если ДокумП.Выбран() > 0 Тогда
    ДокумП.ВыбратьСтроки();
    Пока ДокумП.ПолучитьСтроку() >0 Цикл
    Если ДокумП.Номенклатура = Рег.Номенклатура Тогда
    Кол = ДокумП.Количество;
    Прервать;
    КонецЕсли;

    КонецЦикла;
    ПриходП = "Приход от " + ДокумП.ДатаДок + " " + Кол + " шт.";
    КонецЕсли;
    КонецЕсли;

    Вот момент выделенный красным мне и ненравиться.
    Воспользоваться методом "Рег.ПолучитьСтроку" не могу т.к. при изменении регистра не используется метод "Рег.ПривязатьСтроку"

    Может у кого найдется дельный совет? Или отправьте меня где можно об этом почитать.
    Спасибо.
  2. Lucifer
    Offline

    Lucifer Опытный в 1С

    Регистрация:
    27 фев 2007
    Сообщения:
    91
    Симпатии:
    0
    Баллы:
    26
    Я бы запросом всё сделал.
  3. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    А стандартные отчеты Ведомость по остаткам или Ведомость по партия не устраивают? Там, по-моему все видно - и документ, и количество, и сумма.
  4. Tiger
    Offline

    Tiger Опытный в 1С

    Регистрация:
    12 июл 2006
    Сообщения:
    489
    Симпатии:
    0
    Баллы:
    26
    Однозначно запросом. По регистру ПартииНаличие
  5. TopicStarter Overlay
    AlexFF
    Offline

    AlexFF Разбирающийся

    Регистрация:
    6 мар 2007
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    26
    Спасибо за советы. Посижу помучаюсь.

Поделиться этой страницей