7.7 Определение 1-е 2 -е событие 1С 7.7

Тема в разделе "Установка платформы "1С:Предприятие 7.7"", создана пользователем jeka1234, 22 сен 2013.

  1. TopicStarter Overlay
    jeka1234
    Offline

    jeka1234

    Регистрация:
    22 сен 2013
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Народ помогите есть 2 документа приходная накладная и расходный кассовый для приходной накладной я понял ее движения но для расходно кассового не пойму по чему он мою таблицу значений тбДолги не видит . и она пустая( вот пример
    Код:
    Процедура РассчитатьШапку()
    
    тбДолги = СоздатьОбъект("ТаблицаЗначений");
    тбДолги.НоваяКолонка("Фирма",,,,,,,);
    тбДолги.НоваяКолонка("Контрагент",,,,,,,);
    тбДолги.НоваяКолонка("Договор",,,,,,,);
    тбДолги.НоваяКолонка("Счет",,,,,,,);
    тбДолги.НоваяКолонка("ВидНДС",,,,,,);
    тбДолги.НоваяКолонка("ДокументДолга",,,,,,,);
    тбДолги.НоваяКолонка("СуммаОплаты",,,,,,,);
    КонецПроцедуры
    
    //*****************************************************
    Процедура ДвиженияКредДокумент()
    Перем тбДолги;
    ВремРегистры = СоздатьОбъект("Регистры");
    
    Рег=ВремРегистры.ВзаиморасчетыПокупателей;
    Рег.УстановитьЗначениеФильтра("Фирма",Фирма,1);
    Рег.УстановитьЗначениеФильтра("ДокументДолга",ДокументОснование,1);
    Рег.УстановитьЗначениеФильтра("ВидНДС",ВидНДС,1);
    Если ИтогиАктуальны()=0 Тогда
    Рег.ВременныйРасчет();
    ВремРегистры.РассчитатьРегистрыНа(ТекущийДокумент());
    КонецЕсли;
    
    Рег.ВыгрузитьИтоги(тбДолги,1,1);
    
    СуммаПогашения = СуммаОплаты;
    СтавкаНДСПогашения = ВидНДС;
    
    тбДолги.ВыбратьСтроку();
    Если ДокументОснование.Выбран()=1 Тогда
    Счет = ДокументОснование;
    Иначе
    Счет = ТекущийДокумент();
    КонецЕсли;
    глПогашениеДолга(Контекст, тбДолги, Фирма, Контрагент, Договор, ВидНДС, ДокументОснование, СуммаПогашения);
    
    КонецПроцедуры
    и в глобальном
    Код:
       Процедура глПогашениеДолга(Конт, тбДолги, Фирма, Контрагент, Договор, ВидНДС, Счет, СуммаПогашения) Экспорт
    
    ВидДок = Конт.Вид();
    
    тбДолги.ВыбратьСтроки();
    Пока тбДолги.ПолучитьСтроку()>0 Цикл
    
    Если тбДолги.СуммаДолга<0 Тогда
    Продолжить;
    КонецЕсли;
    
    Если СуммаПогашения=0 Тогда
    Продолжить;
    ИначеЕсли тбДолги.СуммаДолга<=СуммаПогашения Тогда
    //полное погашение документа долга
    тДокументДолга = тбДолги.ДокументДолга;
    тСчет = тбДолги.Счет;
    тСуммаПогашения = тбДолги.СуммаДолга;
    глПогаситьДокументВзаиморасчетов(Конт,1, Фирма, Контрагент, Договор, ВидНДС, тСчет, тДокументДолга, тСуммаПогашения); 
    СуммаПогашения = СуммаПогашения - тСуммаПогашения;
    ИначеЕсли тбДолги.СуммаДолга > СуммаПогашения Тогда
    //частичное погашение
    тДокументДолга = тбДолги.ДокументДолга;
    тСчет = тбДолги.Счет;
    тСуммаПогашения = СуммаПогашения;
    глПогаситьДокументВзаиморасчетов(Конт,1, Фирма, Контрагент, Договор, ВидНДС, тСчет, тДокументДолга, тСуммаПогашения);
    СуммаПогашения = 0;
    КонецЕсли;
    Если тбДолги.СуммаОплаты < СуммаПогашения Тогда // Для расходного кассвого
    тДокументДолга = тбДолги.ДокументДолга;
    тСчет = тбДолги.Счет;
    тСуммаПогашения = СуммаПогашения;
    глПогаситьДокументВзаиморасчетов(Конт,-1, Фирма, Контрагент, Договор, ВидНДС, тСчет, тДокументДолга, тСуммаПогашения);
    
    КонецЕсли;
    КонецЦикла;
    7.7 ПУБ

    Таблица для расходно кассового(ТБДолги) пустая
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Код:
    Рег.ВыгрузитьИтоги(тбДолги,1,1);
    тбДолги.ВыбратьСтроку(); //тут есть что-нибудь?
    
  3. TopicStarter Overlay
    jeka1234
    Offline

    jeka1234

    Регистрация:
    22 сен 2013
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    ну там поидее выгружаю туда значения регистров как в приходной делал тоже самое
  4. TopicStarter Overlay
    jeka1234
    Offline

    jeka1234

    Регистрация:
    22 сен 2013
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    но выбрать стрку там показует что таблица пуста
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Раз таблица пустая - поиграйте фильтрами...
    Код:
    Рег.УстановитьЗначениеФильтра("Фирма",Фирма,1);
    Рег.УстановитьЗначениеФильтра("ДокументДолга",ДокументОснование,1);
    Рег.УстановитьЗначениеФильтра("ВидНДС",ВидНДС,1);
    
  6. TopicStarter Overlay
    jeka1234
    Offline

    jeka1234

    Регистрация:
    22 сен 2013
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Спасибо вам огромное и правда было дело в фильтре очень помогли лучший по 1с сайт)
  7. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Не за что. Обращайтесь
Похожие темы
  1. ANDRE
    Ответов:
    3
    Просмотров:
    556
Загрузка...

Поделиться этой страницей