7.7 Опять про прайс-лист с картинками

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем KatrineKA, 5 июл 2012.

  1. TopicStarter Overlay
    KatrineKA
    Offline

    KatrineKA Опытный в 1С

    Регистрация:
    5 окт 2010
    Сообщения:
    214
    Симпатии:
    0
    Баллы:
    26
    Еще раз о том как вывести на печать картинку номенклатуры.
    Я чего то не допоняла видимо. Картинка не выводится.

    Код:
    Процедура Печать(Докум)
    
    ИсхТабл = СоздатьОбъект("Таблица");
    Картинка = СоздатьОбъект("Картинка");
    
    ИсхТабл.ВывестиСекцию("ШапкаТаблицы");
    
    Путь = "D:\Images\upload";
    
    Ном = 0;
    
    Если Докум.КоличествоСтрок() <> 0 Тогда 
    
    Докум.ВыбратьСтроки();
    Пока Докум.ПолучитьСтроку() = 1 Цикл
    
    Ном = Ном + 1;
    Номенклатура = Докум.Номенклатура; 
    Файл		 = Номенклатура.Картинка;
    Картинка.Загрузить(Путь + "\" + Файл);  
    
    ЕдИзм	    = Докум.Единица;
    Цена		 = Докум.Цена;
    
    ИсхТабл.ВывестиСекцию("Строка");
    КонецЦикла;
    
    КонецЕсли;
    
    ИсхТабл.ТолькоПросмотр(1);
    ИсхТабл.ПараметрыСтраницы(,,,,,,,,,1,,);
    ИсхТабл.Показать();
    
    КонецПроцедуры // Печать()
    
  2. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    что попадает в переменную Файл = Номенклатура.Картинка;? чему в итоге равно вот это "Путь + "\" + Файл"
  3. TopicStarter Overlay
    KatrineKA
    Offline

    KatrineKA Опытный в 1С

    Регистрация:
    5 окт 2010
    Сообщения:
    214
    Симпатии:
    0
    Баллы:
    26
    Файл = Номенклатура.Картинка - имя файла поподает, например 36352.bmp
    "D:\Images\upload\36352.bmp"
  4. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    проверяли? попробуйте вывести в окно сообщений путь и посмотреть...

    я конечно с 7 особо не работала, но предположу, что вот это
    Код:
    ЕдИзм	 = Докум.Единица;
    Цена   = Докум.Цена;
    заполнение параметров секции. Если да, то а где вы выводите картинку?
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Не так надо...
    В макете создаем объект типа рисунок.
    В в расшифровке пишем Рисовать(Таб.ТекущийОбъект, Путь)

    Таб - объект типа таблица
    Путь - файл картинки
    Рисовать - функция модуля
    Код:
    Функция Рисовать(Куда, Откуда)
    Куда.Загрузить(Откуда);
    КонецФункции
    
    все... в коде пишем
    Код:
    Путь="имякартинки";
    Таб.ВывестиСекцию("ХочуКартинку");
    
  6. TopicStarter Overlay
    KatrineKA
    Offline

    KatrineKA Опытный в 1С

    Регистрация:
    5 окт 2010
    Сообщения:
    214
    Симпатии:
    0
    Баллы:
    26
    Все поняла. Спасибо.

Поделиться этой страницей