8.х ОперацияБух, Как исправить проводки

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Muggsy, 9 окт 2008.

  1. TopicStarter Overlay
    Muggsy
    Offline

    Muggsy одно ЭС

    Регистрация:
    10 сен 2008
    Сообщения:
    243
    Симпатии:
    0
    Баллы:
    26
    Есть серия ручных операций, в которых надо исправить счета проводок. Как это сделать программно ума не приложу! :smile: конфигурация Управление страховой компанией
    думаю для других также будет..... :unsure:
  2. lazy
    Offline

    lazy Модераторы Команда форума Модератор

    Регистрация:
    1 сен 2007
    Сообщения:
    2.127
    Симпатии:
    4
    Баллы:
    29
    В первую очередь нужно учитывать, что исправление счетов приведет к тому, что изменится баланс, и нужно будет подавать "уточеннку".

    Во вторую очередь - есть несколько вариантов, вот мой:

    Код:
     
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    Если Документ.Пустая() Тогда // Документ - ссылка на нужный документ Операция
    Возврат; 
    КонецЕсли;
    // работаем с Хозрасчетным регистром. для Налогового, или еще какого - нужно создавать отдельный набор
    НаборЗаписейБух = РегистрыБухгалтерии.Хозрасчетный.СоздатьНаборЗаписей(); 
    НаборЗаписейБух.Отбор.регистратор.Установить(Документ); // отбор по документу - регистратору
    НаборЗаписейБух.Прочитать(); // чтение набора записей
    
    Для каждого Запись из НаборЗаписейБух Цикл // перебор записей
    Если Запись.СчетДт = ПланыСчетов.Хозрасчетный.Аккредитивы Тогда // условие поменять на свое
    Запись.Сумма = 9999999; // реквизит заменить на совй
    КонецЕсли;
    КонецЦикла;
    НаборЗаписейБух.Записать(); // сохраним то, что натворили :-)
    КонецПроцедуры
    
    
    P.S. ИМХО :p
  3. lazy
    Offline

    lazy Модераторы Команда форума Модератор

    Регистрация:
    1 сен 2007
    Сообщения:
    2.127
    Симпатии:
    4
    Баллы:
    29
    Да, забыл уточнить - при работе с суммами, неплохо было бы изменить и сумму документа :)
    Код:
     
    Док = Документ.ПолучитьОбъект();
    Док.СуммаОперации = МояНоваяСумма;
    Док.Записать();
    
    
  4. TopicStarter Overlay
    Muggsy
    Offline

    Muggsy одно ЭС

    Регистрация:
    10 сен 2008
    Сообщения:
    243
    Симпатии:
    0
    Баллы:
    26
    спасибо, я попробую :)

Поделиться этой страницей