7.7 Операция

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем змейкин, 31 мар 2013.

  1. TopicStarter Overlay
    змейкин
    Offline

    змейкин Опытный в 1С

    Регистрация:
    25 мар 2013
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Народ подскажите кто знает как сделать чтобы в операции была выборка по счетам .Например чтобы по выбранному плану счетов счета менялись в зависимости от товаров.Например если выбран товар то 28 счет а если топливо то 203
    Код:
    // ****************************************************
    Ôóíêöèÿ ÏðîâåðêàØàÏêè()
    
    åñëè êîíòðàãåíò.âûáðàí()=0 òîãäà
    âîçâðàò 0;
    èíà÷ååñëè ÌåñòîÕðàíåíèÿ.âûáðàí()=0 òîãäà
    âîçâðàò 0;
    èíà÷ååñëè ÔèðÌà.âûáðàí()=0 òîãäà
    âîçâðàò 0;
    èíà÷å
    âîçâðàò 1;
    êîíåöåñëè;
    
    êîíåöÔóíêöèè
    // ****************************************************
    Ôóíêöèÿ Ïðîâåðêàñòðîêè()
    
    âîçâðàò 1;
    êîíåöÔóíêöèè
    //*****************************************************
    Ïðîöåäóðà Ïðîâîäêèñòðîêà()
    îÏåðàöèÿ.íîâàÿÏðîâîäêà();
    
    îÏåðàöèÿ.äåáåò.ñ÷åò = ñ÷åòÏîêîäó("281");
    îÏåðàöèÿ.äåáåò.ñóáêîíòî(1,òÌö);
    
    îÏåðàöèÿ.êðåäèò.ñ÷åò = ñ÷åòÏîêîäó("631");
    îÏåðàöèÿ.êðåäèò.ñóáêîíòî(1,êîíòðàãåíò);
    îÏåðàöèÿ.êîëè÷åñòâî = ê_âî;
    îÏåðàöèÿ.ñóÌÌà = ñóÌÌà;
    îÏåðàöèÿ.ñîäåðæàíèåÏðîâîäêè = "ÏðèÕîä òîâàðà";
    
    îÏåðàöèÿ.íàØàÔèðÌà = ÔèðÌà;
    êîíåöÏðîöåäóðû
    //*****************************************************
    Ïðîöåäóðà îáðàáîòêàÏðîâåäåíèÿ()
    åñëè ÏðîâåðêàØàÏêè()=0 òîãäà
    ñòàòóñâîçâðàòà(0);
    êîíåöåñëè;
    
    âûáðàòüñòðîêè();
    Ïîêà Ïîëó÷èòüñòðîêó()>0 öèêë
    Ïðîâåðêàñòðîêè();
    êîíåööèêëà;
    âûáðàòüñòðîêè();
    Ïîêà Ïîëó÷èòüñòðîêó()>0 öèêë
    Ïðîâîäêèñòðîêà();
    êîíåööèêëà;
    îÏåðàöèÿ.íàØàÔèðÌà = ÔèðÌà;
    îÏåðàöèÿ.ñóÌÌàîÏåðàöèè = èòîã("ñóÌÌà");
    îÏåðàöèÿ.ñîäåðæàíèå = ÏðèÌå÷àíèå;
    îÏåðàöèÿ.çàÏèñàòü();
    
    êîíåöÏðîöåäóðû
    
    С кодировкой что то не так(
  2. Vlan
    Online

    Vlan Гость Гость

    Код нечитаем.
  3. TopicStarter Overlay
    змейкин
    Offline

    змейкин Опытный в 1С

    Регистрация:
    25 мар 2013
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    через код 1с не проводиться почему то тут на сайте((
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    При вставке кода через буфер обмена не переключили клавиатуру.
    Повторите
  5. TopicStarter Overlay
    змейкин
    Offline

    змейкин Опытный в 1С

    Регистрация:
    25 мар 2013
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Код:
    // ****************************************************
    Функция ПроверкаШапки()
    
    Если Контрагент.Выбран()=0 Тогда
    Возврат 0;
    ИначеЕсли МестоХранения.Выбран()=0 Тогда
    Возврат 0;
    ИначеЕсли Фирма.Выбран()=0 Тогда
    Возврат 0;
    Иначе
    Возврат 1;
    КонецЕсли;
    
    КонецФункции
    // ****************************************************
    Функция ПроверкаСтроки()
    
    Возврат 1;
    КонецФункции
    //*****************************************************
    Процедура ПроводкиСтрока()
    Операция.НоваяПроводка();    //
    Операция.Дебет.Счет = СчетПоКоду("281");
    Операция.Дебет.Субконто(1,ТМЦ);
    Операция.Дебет.Субконто(2,МестоХранения);
    Операция.Кредит.Счет = СчетПоКоду("631");
    Операция.Кредит.Субконто(1,Контрагент);
    Операция.Количество = К_во;
    Операция.Сумма = Сумма;
    Операция.СодержаниеПроводки = "Приход товара";
    
    Операция.НашаФирма = Фирма;
    КонецПроцедуры
    //*****************************************************
    Процедура ОбработкаПроведения()
    Если ПроверкаШапки()=0 Тогда
    СтатусВозврата(0);
    КонецЕсли;
    
    ВыбратьСтроки();
    Пока ПолучитьСтроку()>0 Цикл
    ПроверкаСтроки();
    КонецЦикла;
    ВыбратьСтроки();
    Пока ПолучитьСтроку()>0 Цикл
    ПроводкиСтрока();
    КонецЦикла;
    Операция.НашаФирма = Фирма;
    Операция.СуммаОперации = Итог("Сумма");
    Операция.Содержание = Примечание;
    Операция.Записать();
    
    КонецПроцедуры
    
    нашел свою ошибку решил проблему спасибо)
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    не за что. обращайтесь

Поделиться этой страницей