8.х ОПЕРАЦИЯ НЕ ВЫПОЛНЕНА!

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем serikadze, 13 авг 2008.

  1. WWW123
    Offline

    WWW123 Опытный в 1С

    Регистрация:
    23 фев 2009
    Сообщения:
    181
    Симпатии:
    0
    Баллы:
    26
    Вопрос решился так,
    взял модуль объекта и во всём модуле закоментировал Отказ, примерно следующим образом:
    Код:
     
    Если д_ПроверкаВозможностиЗаписи(Дата) = Ложь Тогда
    //	Отказ = Истина;
    КонецЕсли;
    
    
    
    и всё заработала, не знаю насколько это верно, но агонию у руководства сняло однозначно :angry:
  2. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    мда...
    без комментариев...
  3. Diego
    Offline

    Diego Любитель 1С Команда форума

    Регистрация:
    3 апр 2009
    Сообщения:
    966
    Симпатии:
    2
    Баллы:
    29
    :angry:
    Не знаю насколько верно мое мнение, но похоже Вашему руководству следует поискать нового программиста.
  4. n.s.gnedash
    Offline

    n.s.gnedash Опытный в 1С Команда форума

    Регистрация:
    15 авг 2010
    Сообщения:
    1.358
    Симпатии:
    5
    Баллы:
    29
    Думаю рано, или поздно всплывет... да так,что хрен восстановишь
  5. n.s.gnedash
    Offline

    n.s.gnedash Опытный в 1С Команда форума

    Регистрация:
    15 авг 2010
    Сообщения:
    1.358
    Симпатии:
    5
    Баллы:
    29
    Лучше все кстати закоментриуй
  6. uza
    Offline

    uza 1С, VBA (EXCEL), VB (.NET + WEB)

    Регистрация:
    10 июл 2007
    Сообщения:
    1.845
    Симпатии:
    1
    Баллы:
    29
    Лучше вообще все удалить!
    Включая архивные копии.
    А то вот у некоторых "ну оно было правильно, а потом само стало обратно не так"
  7. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    [warn=Внимание]Я, конечно, понимаю всю прелесть стеба, но давайте прекратим оффтопить. Спасибо.[/warn]
  8. WWW123
    Offline

    WWW123 Опытный в 1С

    Регистрация:
    23 фев 2009
    Сообщения:
    181
    Симпатии:
    0
    Баллы:
    26
    В принципе я вообще не програмист, а прграмисты все уволились... нет бы просто похвалили, а ещё начинают издеваться!
  9. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Проблема в том, что Вы исключили проверку в фукнции д_ПроверкаВозможностиЗаписи
    Сначала стоило посмотреть, что там проверяется.
    Вполне вероятно, что документ и не должен был проводиться.
  10. WWW123
    Offline

    WWW123 Опытный в 1С

    Регистрация:
    23 фев 2009
    Сообщения:
    181
    Симпатии:
    0
    Баллы:
    26
    Ничего там страшного нет:
    Код:
    Функция д_ПроверкаВозможностиЗаписи(ДатаДок) Экспорт
    ДатаЗапретаРедактирования = КонецДня(константы.ДатаЗапретаРедактирования.Получить());
    Если ДатаДок <= ДатаЗапретаРедактирования тогда
    Сообщить("Данная операция невозможна.",СтатусСообщения.Внимание);
    Возврат Ложь;
    Иначе
    Возврат Истина;
    КонецЕсли;
    КонецФункции
    
    
    Это проверка на то что бы операторы не исправляли документы по предидущим (так сказать "закрытым") периодам
  11. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Тем самым, Вы внесли изменения в код, которое повлияет на эту проверку.
    А достаточно было проверить значение константы даты запрета редактирования и переустановить в нужное.

    Т.е. ситуация решалась без вмешательства в код программы.
  12. WWW123
    Offline

    WWW123 Опытный в 1С

    Регистрация:
    23 фев 2009
    Сообщения:
    181
    Симпатии:
    0
    Баллы:
    26
    ЕНсли поможете справится с этим то непременно последую вашему совету:

    Вложения:

  13. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Константу можно изменить программным путем.
    Это будет обработка в одну строку, практически :)
Похожие темы
  1. Реланиум
    Ответов:
    4
    Просмотров:
    2.985
  2. XXL
    Ответов:
    4
    Просмотров:
    1.755
  3. Юленька
    Ответов:
    9
    Просмотров:
    5.129
  4. punkyklan
    Ответов:
    1
    Просмотров:
    868
  5. vitaliy1911
    Ответов:
    5
    Просмотров:
    2.266
Загрузка...

Поделиться этой страницей