7.7 Операция документа

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем SUnWer, 14 фев 2008.

  1. TopicStarter Overlay
    SUnWer
    Offline

    SUnWer

    Регистрация:
    8 ноя 2006
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    нуна сделать внешнюю обработку которая бы перебирала документы "Выписка" в УСН и в место счета 62.1 ставила 62.4...

    я себе это представляю так:

    Код:
    Процедура Выполнить()
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Ит.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода,, "62.1",, 3, "Проводка", "С");
    Ит.ВыбратьПериоды();
    Пока Ит.ПолучитьПериод() = 1 Цикл
    Если Ит.Операция.Кредит.Счет = СчетПоКоду("62.1") Тогда
    Ит.Операция.Кредит.Счет = СчетПоКоду("62.4");
    Ит.Операция.Записать();
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры
    
    
    и тут он начинает ругатся на:

    Ит.Операция.Кредит.Счет = СчетПоКоду("62.4");
    {C:DOCUMENTS AND SETTINGSSUNWERРАБОЧИЙ СТОЛПРОВ.ERT(8)}: Нельзя изменять записанные проводки!
  2. MaxxaM
    Offline

    MaxxaM Опытный в 1С

    Регистрация:
    16 окт 2007
    Сообщения:
    288
    Симпатии:
    2
    Баллы:
    29
    Должны быть открыты права на редактирование операций документа, но такой подход крайне не верен, ведь при перепроведении в том числе и случайном проводки вернутся в первоначальное состояние :unsure:

    Лучше поменять модуль документа и перепровести выписки за нужный период.

    Да я сам не пробовал, но помоему через бухгалтерские итоги эт немного не корректно B)
  3. Akulina
    Offline

    Akulina Опытный в 1С

    Регистрация:
    30 авг 2007
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26
    MaxxaM прав. Счет надо исправлять в документах, а не в проводках, которые сформировались при проведении документа.

Поделиться этой страницей