7.7 Операции документ

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем змейкин, 13 июн 2013.

  1. TopicStarter Overlay
    змейкин
    Offline

    змейкин Опытный в 1С

    Регистрация:
    25 мар 2013
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Код:
    Процедура ВозврОтходы()
    Таб=СоздатьОбъект("Таблица");
    Опер=СоздатьОбъект("Операция");
    Опер.НайтиОперацию(ТекущийДокумент());
    Если Опер.ВыбратьОперацииСПроводками(ТекущийДокумент(),,"201,23;")=1 Тогда
    Док=СоздатьОбъект("Документ.НормыЗатрат");
    
    Таб.ИсходнаяТаблица("ВозвратОтходы");
    Таб.ВывестиСекцию("Секция_1");
    Ном=0;
    Пока Опер.ПолучитьПроводку()=1 Цикл
    Ном=Ном+1;
    Таб.ВывестиСекцию("Секция_2");
    ИтогСумма=Опер.Сумма+ИтогСумма;
    ИтогКол_во=Опер.Количество+ИтогКол_во;
    Сообщить("Таблица построена по продукции!!!");
    КонецЦикла;
    Таб.ВывестиСекцию("Секция_3");
    Таб.ТолькоПросмотр(1);
    Таб.Опции(0, 0, 7, 1,);
    Таб.Показать("ВозвратОтходы");
    КонецЕсли;
    КонецПроцедуры
    
  2. TopicStarter Overlay
    змейкин
    Offline

    змейкин Опытный в 1С

    Регистрация:
    25 мар 2013
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Народ Вопрос!Есть документ"Выпуск Продукции"и"Нормы затрат".Для 1 Документа выпуска продукции есть свой документ "Норм Затрат".Как сделать чтобы выводя печатную форму у меня не попадали элементы других норм затрат других документов а только текущего ВыпускаПродукции.Получается если два документа созданы Норм затрат в один день то в отчете они обединються.
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Без МДшника трудно что-либо сказать. Нужно знать структуру. Выложите.
  4. TopicStarter Overlay
    змейкин
    Offline

    змейкин Опытный в 1С

    Регистрация:
    25 мар 2013
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    http://us.ua/1149936/

Поделиться этой страницей