8.х OLE-соединение между 7.7 и 8

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Sergant666, 2 ноя 2007.

  1. TopicStarter Overlay
    Sergant666
    Offline

    Sergant666

    Регистрация:
    1 ноя 2007
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Может ли кто-нибудь привести пример кода, как установить Ole-соединение между базами 7.7 и 8 из восьмерки.
  2. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
    Код:
    V7 = Новый COMобъект("V77.Application");
    
    // пытаемся открыть базу
    Если Не V7.Initialize(V7.RMTrade,"""C:Program FilesCv77BINcv7.exe"" enterprise /D """+ПутьКБазе+"""  /N Директор","NO_SPLASH_SHOW") Тогда
    Предупреждение("Ошибка открытия информационной базы!
    |Возможно требуется переиндексировать БД 7.7 !");
    V7=Ложь;
    Возврат;
    КонецЕсли; 
    Состояние("База успешно открыта");
    
    
    Далее работаешь с объектом v7

    СправочникНоменклатураВ7 = V7.CreateObject("Справочник.Номенклатура");
  3. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Код:
    Попытка
    База = Новый COMОбъект("V8.COMConnector");
    Соединение = База.Connect("File=""" + ПутьКБазе + """; Usr =""" + ИмяПользователяБазы + """;");
    Исключение
    Отказ = Истина;
    Общий.СообщитьОбОшибке("Не удалось получить доступ к базе данных по адресу: " + ПутьКБазе);
    Отказ = Истина;
    КонецПопытки;
    
    
  4. Эмин
    Offline

    Эмин Руководитель проектов

    Регистрация:
    25 май 2007
    Сообщения:
    1.178
    Симпатии:
    1
    Баллы:
    26
    Код:
    Если ПустаяСтрока(ПутьКИБ) Тогда
    //СООБЩИТЬ ОБ ОШИБКЕ В ПАРАМЕТРАХ
    КонецЕсли;
    
    V7 = Новый ComОбъект("V77.Application"); 
    СтрокаПараметров="/D"""+СокрЛП(ПутьКИБ)+ """ /E";
    Если Не ПустаяСтрока(Имя) Тогда
    СтрокаПараметров = СтрокаПараметров +  " /N" + СокрЛП(Имя);
    КонецЕсли;
    Если Не ПустаяСтрока(Пароль) Тогда
    СтрокаПараметров = СтрокаПараметров +  " /P" + СокрЛП(Пароль);
    КонецЕсли;
    
    Если V7.Initialize(V7.RMTrade, СтрокаПараметров, "NO_SPLASH_SHOW") = 0 Тогда
    //СООБЩИТЬ ОБ ОШИБКЕ
    КонецЕсли;
    
    
    Ну и в конце рекоменгдую все созданные переменные 77 приравнять нулю - очистить ссылки и закрыть соединения.

    Код:
    V7 = 0;
    
    
  5. TopicStarter Overlay
    Sergant666
    Offline

    Sergant666

    Регистрация:
    1 ноя 2007
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Отлично, спасибо всем, кто ответил! Сегодня вечером попробую.
Похожие темы
  1. Oleg_NSK
    Ответов:
    1
    Просмотров:
    387
  2. qwertyu
    Ответов:
    2
    Просмотров:
    387
Загрузка...

Поделиться этой страницей