7.7 Округление

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем eXpert, 3 ноя 2011.

  1. TopicStarter Overlay
    eXpert
    Offline

    eXpert

    Регистрация:
    3 ноя 2011
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте! Очень нужна помощь с округлением розничной цены при вводе товара!
    Значения в сумме до 25 рублей отбрасываются, от 25 рублей включительно до 75 рублей округляются до 50 рублей, от 75 рублей включительно и выше округляются до 100 рублей.

    если 7810 р. то получится 7800
    если 7840 р. то получится 7850
    если 7880 р. то получится 7900

    Пожалуйста помогите!
  2. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    могу ошибаться, но думаю штатными средствами такого не добиться, а вот ручками - думаю реально, только придется доработать
  3. Бухгалтерский угодник
    Online

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.196
    Симпатии:
    494
    Баллы:
    104
    Только писать свою функцию округления т.к. ы данном случае правила математики не срабатывают
  4. Ivasishinav
    Offline

    Ivasishinav

    Регистрация:
    3 июл 2017
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Добрый день!
    Может подскажите, в 1с 7.7 редакция 4.5 Мисофт никак не получается сделать, чтобы счет-фактура не округляла до целого числа НДС и Сумму. Два дня почти везде менял разрядность - все без толку. В модуле это изменить не получается. Может подскажите волшебную строчку? =)
    [​IMG]

    Код:

    ИначеЕсли (ИмяРеквизита = "Количество"[​IMG] Тогда
    Сумма = ОКР((Цена*Количество),ОКРУГЛЕНИЕ,1);
    РассчитатьНалоги();
    Всего = глПоказательДокумента(Контекст, "СуммаСНалогами"[​IMG];
    ИначеЕсли (ИмяРеквизита = "Цена"[​IMG] Тогда
    Сумма = ОКР((Цена*Количество),ОКРУГЛЕНИЕ,1);
    РассчитатьНалоги();






    Меняю во 2 и 6 строке слово округление на 2 и ничего не меняется

    есть еще в конце модуля процедура самого округления, может ее как-то изменить?





    Процедура Округление()
    Если ПустоеЗначение(ОкруглятьДо) = 1 Тогда
    Сообщить("Не задан способ округления"[​IMG];
    Возврат;
    КонецЕсли;


    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл
    СпособОкргления = ОкруглятьДо;
    Округление = Число(СокрЛП(Строка(СпособОкргления)));
    п = Цена - Цел(Цена/Округление)*Округление;
    Если (п < Округление/2) Тогда
    Цена= Цел(Цена/Округление)*Округление;
    ИначеЕсли (Округление/2 <= п) и (п < (Округление/2+Округление)) Тогда
    Цена = Цел(Цена/Округление)*Округление + Округление;
    ИначеЕсли (п >= (Округление/2+Округление)) Тогда
    Цена = Цел(Цена/Округление)*Округление + Округление*2;
    КонецЕсли;
    Пересчет("Цена"[​IMG];
    КонецЦикла;
    КонецПроцедуры



    Процедура РассчитатьНалоги()

    НДС = глПоказательДокумента(Контекст, "НДС");
    НП = глПоказательДокумента(Контекст, "НП");
    Всего = глПоказательДокумента(Контекст, "СуммаСНалогами");
    Форма.НДС.Видимость(глПризнакУчетаНалога(Контекст, "НДС"));
    //Форма.НП.Видимость(глПризнакУчетаНалога(Контекст, "НП"));

    КонецПроцедуры // РассчитатьНалоги()
  5. Бухгалтерский угодник
    Online

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.196
    Симпатии:
    494
    Баллы:
    104
    А вы посмотрите в метаданных.. М.б. Сумма это реквизит типа число с разрядностью дробной части 0
  6. Ivasishinav
    Offline

    Ivasishinav

    Регистрация:
    3 июл 2017
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    спасибо, решение уже найдено. червяк скрывался в глобальном модуле "глПоказательДокумента" округление
  7. Бухгалтерский угодник
    Online

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.196
    Симпатии:
    494
    Баллы:
    104
Похожие темы
  1. Siana
    Ответов:
    5
    Просмотров:
    2.019
  2. Sherry Djeanna
    Ответов:
    10
    Просмотров:
    1.366
Загрузка...

Поделиться этой страницей