8.х Ограничение Вывода на печать.

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем бухг123, 24 окт 2013.

  1. TopicStarter Overlay
    бухг123
    Offline

    бухг123 Опытный в 1С

    Регистрация:
    8 дек 2011
    Сообщения:
    219
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте.

    Подскажите пожалуйста как добиться того чтобы Пользователь мог печатать только некоторые макеты (печатные формы). Можно этого добиться не прописывая в каждом документе проверку на пользователя и Возврат, или Отказ.
    RLS (органичение) на право "Вывод" не активно, поставить не получается.

    Конфигурация Комплексная Автоматизация 1.1
  2. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    нет такого механизма нет т.к есть еще и внешние печатные формы (их то кстати модно ограничить), а вот стандартные нет
  3. TopicStarter Overlay
    бухг123
    Offline

    бухг123 Опытный в 1С

    Регистрация:
    8 дек 2011
    Сообщения:
    219
    Симпатии:
    0
    Баллы:
    26
    Я пробовал прикрепить её как внешнюю печатную форму (пробовал делать также печатную форму с простым выводом реквизитов справочника к примеру) но и на неё распространяется запрет для вывода на печать (т.е. настройки параметров, вывод на печать, и тд.)
    Уже пробую на на момент печати добавить роль (ПолныеПрава), т.к. эта роль обладает возможностью право "Вывод". А далее их убирать, но пока не получается. Программно с ролями не работал никогда да и об этом мало что написано.
    Код:
     Выборка = ПользователиИнформационнойБазы.ПолучитьПользователей();
    
    Для Каждого ЭлементМассива Из Выборка Цикл
    ИмяПользователя = ЭлементМассива.Имя;
    Если ИмяПользователя = "Иванов" Тогда
    Роль = ЭлементМассива.Роли;
    Для каждого Ролли Из Роль Цикл
    Сообщить(Ролли.Имя);
    КонецЦикла;
    КонецЕсли;
    КонецЦикла;
    
  4. TopicStarter Overlay
    бухг123
    Offline

    бухг123 Опытный в 1С

    Регистрация:
    8 дек 2011
    Сообщения:
    219
    Симпатии:
    0
    Баллы:
    26
    Вариант с ролями не совсем подходит. Может кто решал подобное. Подскажите как решали?

    Вложения:

  5. TopicStarter Overlay
    бухг123
    Offline

    бухг123 Опытный в 1С

    Регистрация:
    8 дек 2011
    Сообщения:
    219
    Симпатии:
    0
    Баллы:
    26
    Т.е при выводе на печать, если у пользователя нет роли у которой есть право "Вывод" открывается окно с неактивными операциями "Печать", "Предварительные просмотр" и тд (см. ниже).
    Как можно, добавлением ли внешней обработки с какими либо условиями или с небольшими изменениями в конфигурации или еще как, пользоваться выводом на печать печатной формы?

    Вложения:

  6. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    Задачу конкретней поставьте.
    Пользователь не должен печатать какие формы?
    1. Втроенные или внешние
    2. Если втроенные то какие должен какие нет. допустим Торг -12 может а С\ф нет.
  7. TopicStarter Overlay
    бухг123
    Offline

    бухг123 Опытный в 1С

    Регистрация:
    8 дек 2011
    Сообщения:
    219
    Симпатии:
    0
    Баллы:
    26
    Изначально - не может печатать встроенные формы кроме например одной только Счет-Фактура выданный. (у пользователя не должно стоять право "Вывод" или если это право стоит, остальные документы он не должен выводить на печать)
    Если это не возможно то хотя-бы как добиться того же самого для внешней печатной формы. (это право "Вывод" распространяется и для внешних форм)
  8. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    Для ВПФ все просто - есть ограничение на права доступа на уровне записей выносите их в отдельную папку в справочник назначаете на нее права.
    Что же касается печатать только с\ф то как вариант, это ограничить через вывод и ВПФ сделать или обработку на нужный док, которая бы печатную форму сохраняла в эксель например и все. и уже из экселя печатай
  9. TopicStarter Overlay
    бухг123
    Offline

    бухг123 Опытный в 1С

    Регистрация:
    8 дек 2011
    Сообщения:
    219
    Симпатии:
    0
    Баллы:
    26
    Спасибо, попробую.
  10. TopicStarter Overlay
    бухг123
    Offline

    бухг123 Опытный в 1С

    Регистрация:
    8 дек 2011
    Сообщения:
    219
    Симпатии:
    0
    Баллы:
    26
    (Если делать через RLS на роль) Пробую поставить ограничение в роль ну к примеру "Полные права" не активна такая возможность. Не там смотрю?

    В отдельную папку выносить что?

    Вложения:

Поделиться этой страницей