8.х УТ Ограничение в правах пользователей.

Тема в разделе ""1С:Управление торговлей УТ"", создана пользователем Lukish, 4 июл 2012.

  1. TopicStarter Overlay
    Lukish
    Offline

    Lukish Опытный в 1С

    Регистрация:
    2 июл 2012
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26
    Ещё раз всем здравствуйте! :)
    Есть вопрос, при чём на первый взгляд очень простой...Но интернет не смог дать мне конкретного ответа..поэтому прошу помощи у вас :)
    Так вот, создаёт наш кладовщик в 1с свои документы...а другие пользователи их открывают и редактируют не так как ему надо..Вот собственно и вопрос:​

    Как запретить изменять пользователям ЧУЖИЕ документы?
    либо
    Как запретить всем пользователям менять ВСЕ документы КОНКРЕТНОГО пользователя?

    Надеюсь на помощь-заранее спасибо =)​
  2. TopicStarter Overlay
    Lukish
    Offline

    Lukish Опытный в 1С

    Регистрация:
    2 июл 2012
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26
    Насколько я понял - в программе это не предусмотрено, и нужно прописывать команды?
  3. gennadyantropov
    Offline

    gennadyantropov Новичок в 1С

    Регистрация:
    19 июл 2011
    Сообщения:
    29
    Симпатии:
    3
    Баллы:
    4
    Правильно. В общий модуль НастройкаПравДоступа в процедуру ПроверкаПериодаДокумента вставьте код

    Код:
    Если ДокументОбъект.Ответственный <> ПараметрыСеанса.ТекущийПользователь Тогда
    Отказ = Истина;
    Сообщить("Документ может изменять только его ответственный!");
    Возврат;
    КонецЕсли; 
  4. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    В Ваших доках наверняка имеется реквизит "Ответственный", можно проверять пользователя, который пытается записать док, что-то типа:

    Код:
    Процедура ПередЗаписью()
    Если (НЕ ЭтоНовый()) И (Ответственный <> ИмяПользователя()) Тогда Сообщить("Вам запрещено редактировать данный документ");
    КонецЕсли;
    КонецПроцедуры
    ...опередили))
  5. TopicStarter Overlay
    Lukish
    Offline

    Lukish Опытный в 1С

    Регистрация:
    2 июл 2012
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26
    Большое спасибо =) Завтра на работу приду-буду делать :)
  6. TopicStarter Overlay
    Lukish
    Offline

    Lukish Опытный в 1С

    Регистрация:
    2 июл 2012
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26
    Я вот только не понял...это в каждый документ прописывать данный код? Мне нужно что бы и то что есть сейчас, и то что будет после-никто не мог редактировать кроме данного пользователя... Я только только начал всё это осваивать-поэтому мало что понимаю).. Не могу пока даже сообразить где найти этот общий модуль))
  7. TopicStarter Overlay
    Lukish
    Offline

    Lukish Опытный в 1С

    Регистрация:
    2 июл 2012
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26
    Всё разобрался :) ....вот только сейчас немогу сообразить,rshakiro , куда в какую процедуру вставлять ваш текст? =) Тут нет процедуры ПередЗаписью..вернее есть, но их несколько и она по разному звучат)
  8. TopicStarter Overlay
    Lukish
    Offline

    Lukish Опытный в 1С

    Регистрация:
    2 июл 2012
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26
    Ой..и сталкнулся с проблемой...Не редактирует он мне её...Прочитал что нужно снятт с поддержки, но в конфигурации-поддержки- пункт Настройка поддержки неактивен....хм...
  9. TopicStarter Overlay
    Lukish
    Offline

    Lukish Опытный в 1С

    Регистрация:
    2 июл 2012
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26
    Сразу скажу что конфа не базовая.
  10. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.750
    Симпатии:
    509
    Баллы:
    204
    Ну так снимайте тогда с поддержки.
    А чтобы в каждом доке не прописывать, можно сделать подписку на событие.
  11. TopicStarter Overlay
    Lukish
    Offline

    Lukish Опытный в 1С

    Регистрация:
    2 июл 2012
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26

    Вложения:

    • 1.PNG
      1.PNG
      Размер файла:
      72 КБ
      Просмотров:
      55
    • 2.png
      2.png
      Размер файла:
      121,9 КБ
      Просмотров:
      72
    • 3.PNG
      3.PNG
      Размер файла:
      128,9 КБ
      Просмотров:
      61
  12. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.750
    Симпатии:
    509
    Баллы:
    204
    Странно, а вы под полными правами в конфу заходите ?
  13. TopicStarter Overlay
    Lukish
    Offline

    Lukish Опытный в 1С

    Регистрация:
    2 июл 2012
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26
    Да-под администратором
  14. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.750
    Симпатии:
    509
    Баллы:
    204
    В корень конфигурации перейдите.
  15. TopicStarter Overlay
    Lukish
    Offline

    Lukish Опытный в 1С

    Регистрация:
    2 июл 2012
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26

    Вложения:

    • 4.PNG
      4.PNG
      Размер файла:
      160,8 КБ
      Просмотров:
      24
  16. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    Покажите скрин прав пользователя, под которым заходите
  17. TopicStarter Overlay
    Lukish
    Offline

    Lukish Опытный в 1С

    Регистрация:
    2 июл 2012
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26

    Вложения:

    • 5.PNG
      5.PNG
      Размер файла:
      161 КБ
      Просмотров:
      21
    • 6.PNG
      6.PNG
      Размер файла:
      111 КБ
      Просмотров:
      21
  18. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    По порядку
    Читайте пожалуйста статьи которые пишут именно для начинающих пользователей, мы про то что пишем уже все знаем.
    [topic='43161']Рубрика для начинающих: Как узнать является ли Ваша конфигурация типовой (1С: Предприятие 8)[/topic]
    1. Открываем конфигурацию
    Посмотреть вложение 11494
    2. Открывает возможность редактирования
    Посмотреть вложение 11495
    3. В открывшемся окне включаем возможность изменения. Подробнее ([topic='43161']Рубрика для начинающих: Как узнать является ли Ваша конфигурация типовой (1С: Предприятие 8)[/topic])
    Посмотреть вложение 11496
    4. Открываем снова это окно и далее по рисунку
    Посмотреть вложение 11498
    Также поступаем
    Посмотреть вложение 11499
    После включения изменения обновляем конфигурацию (кнопка F7)
    5. В дереве конфигурации находим ветку "Планы видов характеристик", ниже "Права пользователей" и делаем как показано на рисунке ниже
    Посмотреть вложение 11497
    6. В открывшемся окне добавляем новую запись
    Посмотреть вложение 11500
    7. Далее открываем модули форм по пункту 4 и делаем как ранее предложено, однако рекомендую не привязываться к ролям, а привязать к правам
    Код:
    // Процедура - обработчик события "ПередОткрытием" формы.
    //
    Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
    Если ЭтоНовый()
    И ЗначениеЗаполнено(ПараметрОснование)
    И ТипЗнч(ПараметрОснование) = Тип("ДокументСсылка.ЗаказПокупателя")
    И НЕ ПараметрОснование.Проведен Тогда
    
    ТекстВопроса = "Заказ покупателя не проведен, документ не будет заполнен, продолжить?";
    Ответ = Вопрос(ТекстВопроса, РежимДиалогаВопрос.ДаНет,, КодВозвратаДиалога.Да);
    Если Ответ = КодВозвратаДиалога.Нет Тогда
    Отказ = Истина;
    КонецЕсли;
    
    КонецЕсли;
    
    // Добавлено +
    Если НЕ ЭтоНовый() Тогда
    Если НЕ Ответственный = ПараметрыСеанса.ТекущийПользователь И НЕ
    УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(ПараметрыСеанса.ТекущийПользователь, "РазрешитьПросмотрДокументовДругихПользователей" Тогда
    ЭтаФорма.ТолькоПросмотр = Истина;
    КонецЕсли;
    КонецЕсли;
    // Добавлено -
    
    + когда документ открывается, форма уже не активна и пользователь понимает что документ можно только посмотреть и не будет лишних действий по наполнению документа которые порой могут занимать даже не один час, а в реализованном Выше методе пользователь поймет что записать документ нельзя когда уже закончит его редактирование
    - Минусом является тот факт, что нельзя использовать подписку на событие и для каждого вида документа нужно будет вставлять данный участок кода, т.е. изменений в базе будет на порядок больше.
    ПРИМЕРНО ТАК

    Вложения:

  19. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.750
    Симпатии:
    509
    Баллы:
    204
    Установите курсор в корень конфы, далее то что у вас на втором скрине в 11-м посте.
  20. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    Ребята, не я.....те мучайте судьбу, у него просто конфа не открыта :D
    Он файл конфы открыл, внешний файл, а не конфу ИБ, делай как ранее написано и все

Поделиться этой страницей