8.х Ограничение размера сохраняемого файла

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Valeo, 8 апр 2011.

  1. TopicStarter Overlay
    Valeo
    Offline

    Valeo

    Регистрация:
    4 апр 2011
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Кто знает, подскажите, как можно ограничить максимальный размер сохряняемого файла в хранилище дополнит. информации? Например max 200 КБ?
  2. Diego
    Offline

    Diego Любитель 1С Команда форума

    Регистрация:
    3 апр 2009
    Сообщения:
    966
    Симпатии:
    2
    Баллы:
    29
    У меня рисунки в базу вот так сохраняются:

    Код:
    Перем СтруктураИзображения, Хранилище;
    Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    Диалог.Заголовок = "Выберите изображение...";
    Диалог.Фильтр = "Картинки (*.jpg)|*.jpg";
    Диалог.ПредварительныйПросмотр = Истина;
    Диалог.ПроверятьСуществованиеФайла = Истина;
    Диалог.МножественныйВыбор = Ложь;
    
    Если Диалог.Выбрать() Тогда
    
    Массив = НайтиФайлы(Диалог.Каталог,Сред(Диалог.ПолноеИмяФайла, СтрДлина(Диалог.Каталог) + 1));
    Если Массив.Количество()>0 Тогда
    РазмерФайла = Формат(Массив[0].Размер(),"ЧГ=0");
    РазмерФайла = Число(Массив[0].Размер());
    КонецЕсли;
    Если РазмерФайла > 102400 Тогда
    Предупреждение("       Размер файла больше 100 Кб !" + Символы.ПС +
    "Сожмите рисунок до указанного размера" + Символы.ПС +
    "           и попробуйте еще раз",,"Слишком большой файл");
    Возврат;
    КонецЕсли;
    
    // Сохраняем полученное изображение товара в структуре вместе
    // с его именем файла.
    СтруктураИзображения = Новый Структура;
    
    СтруктураИзображения.Вставить("ИмяФайла", Сред(Диалог.ПолноеИмяФайла, СтрДлина(Диалог.Каталог) + 1));
    СтруктураИзображения.Вставить("Картинка", Новый Картинка(СтруктураИзображения.ИмяФайла));
    
    Хранилище = Новый ХранилищеЗначения(СтруктураИзображения, Новый СжатиеДанных());
    Элемент = ЭлементыФормы.ВидыРисунка.ТекущиеДанные.Изображение;
    ЭлементыФормы.ВидыРисунка.ТекущиеДанные.Изображение = Хранилище;
    
    // Устанавливаем выбранное изображение в поле картинки
    ЭлементыФормы.Изображение.Картинка = СтруктураИзображения.Картинка;
    
    Иначе
    Возврат;
    КонецЕсли;
    
    
    
  3. TopicStarter Overlay
    Valeo
    Offline

    Valeo

    Регистрация:
    4 апр 2011
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    У меня при выборе файла картинки пишет ошибку
    {Форма.Форма(166)}: Операции сравнения на больше-меньше допустимы только для значений совпадающих примитивных типов (Булево, Число, Строка, Дата)
  4. Diego
    Offline

    Diego Любитель 1С Команда форума

    Регистрация:
    3 апр 2009
    Сообщения:
    966
    Симпатии:
    2
    Баллы:
    29
    Странно, я код не набирал,а скопипастил из работающей базы.
    А если глянуть в отладчике, что находится в переменной РазмерФайла, перед тем как ее сравниваете?

    Ну или посмотреть через Сообщить(РазмерФайла);

Поделиться этой страницей