7.7 Ограничение прав пользователей

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем Deathtroyer, 28 мар 2012.

  1. TopicStarter Overlay
    Deathtroyer
    Offline

    Deathtroyer

    Регистрация:
    27 мар 2012
    Сообщения:
    39
    Симпатии:
    0
    Баллы:
    1
    в Процедуре ПриОткрытии() но вот это где я найти не могу....
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    кн. Формы. Выбрали нужную. Закладка модуль....

    Вышеописанный код
    http://www.1c-pro.ru/topic40962.html/page__view__findpost__p__206633
    в процедуре ПриОткрытии только навредит
  3. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    Бросьте файл .MD
  4. TopicStarter Overlay
    Deathtroyer
    Offline

    Deathtroyer

    Регистрация:
    27 мар 2012
    Сообщения:
    39
    Симпатии:
    0
    Баллы:
    1
    ЗАкладка модуль да....но если при открытии навредит то как лучше?куда ставить вышепредложенную часть кода?
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Смысл? Не понятно что человеку нужно от журнала

    Уточните задачу
  6. TopicStarter Overlay
    Deathtroyer
    Offline

    Deathtroyer

    Регистрация:
    27 мар 2012
    Сообщения:
    39
    Симпатии:
    0
    Баллы:
    1
    а куда бросить?и где найти?)

    Извините что задаю много вопросов, просто хотелось бы разобраться еще и для себя.

    Задача в том.чтобы менеджеры видели только свои счет фактуры.
  7. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    Найдите Документ.СчетФактура откройте модуль формы, найдите процедуру ПриОткрытии() скопируйте сюда...
    А лучше обратиться к специалисту ))))
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    1) МД в файлообменник и сюда ссылку
    2) По доступу - непонятно зачем вам вышеприведенный код про валюту...
    Почитайте про процедуры
    УстановитьОтбор (ваш фильтр)
    ПриУстановкеОтбора (чтобы особо умные юзера не смогли снять отбор интерактивно)
  9. TopicStarter Overlay
    Deathtroyer
    Offline

    Deathtroyer

    Регистрация:
    27 мар 2012
    Сообщения:
    39
    Симпатии:
    0
    Баллы:
    1
    во...нашел...


    //
    Процедура ПриОткрытии()

    // Заполним таблицу для выбора печатной формы
    НомерТекущейФормы = глУстановкаКнопкиПечать(Контекст, "Документ." + Вид(),ТаблицаПечФорм);

    Парам = Форма.Параметр;
    Если ТипЗначенияСтр(Парам)="СписокЗначений" Тогда
    Если ПустоеЗначение(Парам.Получить("Команда"))=1 Тогда
    Сообщить("В форму документа "+Вид()+" передан неверный параметр!","I");
    СтатусВозврата(0);Возврат;
    КонецЕсли;
    Если Парам.Получить("Команда") = "ПечатьНаПринтер" Тогда
    КолЭкз = Макс(Число(Парам.Получить("КолЭкз")),1);
    ПоКнопкеПечать(1,КолЭкз);
    СтатусВозврата(0);Возврат;
    ИначеЕсли Парам.Получить("Команда") = "ПечатьНаЭкран" Тогда
    ПоКнопкеПечать(0);
    СтатусВозврата(0);Возврат;
    ИначеЕсли Парам.Получить("Команда") = "Записать" Тогда
    ДатаДок = Парам.Получить("ДатаСчета");
    УстановитьНовыйНомер(СокрЛП(Константа.ПрефиксИБ) + СокрЛП(Фирма.ЮрЛицо.ПрефиксНомеровДокументов));

    АвтоВремяКонецДня();
    Записать();
    СтатусВозврата(0);
    Возврат;
    Иначе
    Сообщить("В форму документа "+Вид()+" передана неверная команда "+Парам.Получить("Команда")+"!","I");
    СтатусВозврата(0);Возврат;
    КонецЕсли;
    Иначе
    КонтекстОснования = Парам;
    КонецЕсли;

    http://dl.dropbox.com/u/6236130/1%D0%A1.jpg вот может со скрином лучше будет)
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
  11. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    Вот сюда попробуйте вставить НАШ код ))))
  12. TopicStarter Overlay
    Deathtroyer
    Offline

    Deathtroyer

    Регистрация:
    27 мар 2012
    Сообщения:
    39
    Симпатии:
    0
    Баллы:
    1
    Ну вот куда здесь ставить

    Код:
    Права = НазваниеНабораПрав();
    Если (Права = "ПолныеПрава") Тогда
    Иначе
    Если глПользователь <> Автор Тогда
    СтатусВозврата(0);
    Возврат;
    КонецЕсли;
    КонецЕсли;
    
    ?
    
    Процедура ПриОткрытии()
    
    Права = Администратор();
    Если (Права = "ПолныеПрава") Тогда
    Иначе
    Если глПользователь <> Автор Тогда
    СтатусВозврата(0);
    Возврат;
    КонецЕсли;
    КонецЕсли;
    // Заполним таблицу для выбора печатной формы
    НомерТекущейФормы = глУстановкаКнопкиПечать(Контекст, "Документ." + Вид(),ТаблицаПечФорм);
    
    Парам = Форма.Параметр;
    Если ТипЗначенияСтр(Парам)="СписокЗначений" Тогда
    Если ПустоеЗначение(Парам.Получить("Команда"))=1 Тогда
    Сообщить("В форму документа "+Вид()+" передан неверный параметр!","I");
    СтатусВозврата(0);Возврат;
    КонецЕсли;
    Если Парам.Получить("Команда") = "ПечатьНаПринтер" Тогда
    КолЭкз = Макс(Число(Парам.Получить("КолЭкз")),1);
    ПоКнопкеПечать(1,КолЭкз);
    СтатусВозврата(0);Возврат;
    ИначеЕсли Парам.Получить("Команда") = "ПечатьНаЭкран" Тогда
    ПоКнопкеПечать(0);
    СтатусВозврата(0);Возврат;
    ИначеЕсли Парам.Получить("Команда") = "Записать" Тогда
    ДатаДок = Парам.Получить("ДатаСчета");
    УстановитьНовыйНомер(СокрЛП(Константа.ПрефиксИБ) + СокрЛП(Фирма.ЮрЛицо.ПрефиксНомеровДокументов));
    
    АвтоВремяКонецДня();
    Записать();
    СтатусВозврата(0);
    Возврат;
    Иначе
    Сообщить("В форму документа "+Вид()+" передана неверная команда "+Парам.Получить("Команда")+"!","I");
    СтатусВозврата(0);Возврат;
    КонецЕсли;
    Иначе
    
    Так будет верно?
  13. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    После строки ПриОткрытии()
    Только строку потеряли
    Код:
    Права = НазваниеНабораПрав();
  14. TopicStarter Overlay
    Deathtroyer
    Offline

    Deathtroyer

    Регистрация:
    27 мар 2012
    Сообщения:
    39
    Симпатии:
    0
    Баллы:
    1
    а...то есть она так и должна быть Права = НазваниеНаборПрав( );
    ок)))Спасибо,сейчас попробую
  15. TopicStarter Overlay
    Deathtroyer
    Offline

    Deathtroyer

    Регистрация:
    27 мар 2012
    Сообщения:
    39
    Симпатии:
    0
    Баллы:
    1
    Ребят спасибо за терпение.Со чет фактурой сработало.Последний вопрос, не менее важный))))) (спасибо за терпение)

    а как сделать чтобы при заходе в общий журнал манагеры вимдели только свои счета на оплату и распоряжения?Это можно настроить не программно? (ну я имею ввиду ролями или правами)?
  16. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    Копать нужно в сторону Отбора в журнале... наверное лучше Вам обратиться к специалистам
  17. TopicStarter Overlay
    Deathtroyer
    Offline

    Deathtroyer

    Регистрация:
    27 мар 2012
    Сообщения:
    39
    Симпатии:
    0
    Баллы:
    1
    Да я бы с удовольствием обратился, но мое руководство, ни в какую не хочет выделять на это финансов и село на шею мне.Поэтому приходится копать самому((((
  18. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    По поводу ограничения видимости в журнале я вам отвечал в #28 данной темы
    http://www.1c-pro.ru/topic40962.html/page__view__findpost__p__206686

    Обратите внимание что работа будет кропотливая. Нужно учесть ВСЕ варианты ВО ВСЕХ журналах, А у каждого журнала есть (может быть) несколько форм...
    Ну и прочие "дырки" в виде дерева структуры подчиненности скажем....
  19. TopicStarter Overlay
    Deathtroyer
    Offline

    Deathtroyer

    Регистрация:
    27 мар 2012
    Сообщения:
    39
    Симпатии:
    0
    Баллы:
    1
    ну а ограничивать опять же программным кодом?или можно настроить?

    а работы мы не боимся))))все новое нам интересно)
  20. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Исключительно программно

Поделиться этой страницей