7.7 Ограничение прав пользователей 1С7.7Бух

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем AlexLAV, 4 авг 2009.

  1. TopicStarter Overlay
    AlexLAV
    Offline

    AlexLAV

    Регистрация:
    4 авг 2009
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Конфигурация 1С 7.7 Бух 507 Проф.
    С прошлой недели была поставлена задача - Урезать права 2-му буху, т.е. чтобы она могла открывать только несколько счетов (01; 10; 19; 60; 62; 68.2; 71; 90 и 97). Убил кучу времени, но конца и края не видать.
    Что сделано (частично с посторонней помошью):
    Разградил права в конфигураторе (пока частично - не до конца понял, что мона убрать, а что нет :smile: ),
    создал внешний ОСВпоСчету (Только по указанным выше счетам).

    С чем мучаюсь:
    Анализ счета,
    Анализ счета по субконто,
    Анализ субконто,
    Акт сверки
    - то есть нужно всего несколько отчетов для этого буха, а все остальное спрятать от неё
    Спрятать план счетов.

    Главное условие ГлавБуха - чтобы ни кто зарплатные дела не видел - (Был уже прецендент со слезами :unsure: )

    Вообщем караул :aua: , если кому не трудно, помогите, подскажите как эти отчеты переделать и какие нужны права буху настроить для работы только с вышеуказанными счетами.
    Заранее спасибки всем отклинувшимся.
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    А зачем такие сложности? Анализируйте выбранные счетв диалоге формы отчета и запрерить/разрешить формирование (в.т. и расшифровку).

    З.Ы. А главный бухгалтер у вас ЗВЕРЬ и САТРАП
  3. TopicStarter Overlay
    AlexLAV
    Offline

    AlexLAV

    Регистрация:
    4 авг 2009
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    А чуть-чуть поподробнее можно про это:
    А Бух?
    БУХ просто ЗВЕРЬ
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Пример ограничения для ОСВ по счету.
    Код:
    Процедура ПриВыбореСчета()
    Если НазваниеНабораПрав()="НесчастныйЗамБух" Тогда  //не знаю название прав для того которому
    //  кислород перекрыли
    Если Счет<>СчетПоКоду("10") Тогда  //остальные сам допишешь
    Предупреждение("ограничение доступа");
    Счет="";
    Возврат;
    КонецЕсли;
    КонецЕсли;
    ///далее следует стандартный текст
    КонецПроцедуры
    
    
    
  5. TopicStarter Overlay
    AlexLAV
    Offline

    AlexLAV

    Регистрация:
    4 авг 2009
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Вот спасибо :smile:
    А я ужо начал тормозить и видимо еще не скоро остановлюсь :vis: -
    Из недавнего: (минут 30 назад) бух попросила в печатной форме акта оказания услуг, к полю заказчика добавить (его адрес и телефон) и только сейчас сообразил как делать :unsure: - да-а-а уж наверное действительно пора уехать за город на пару недель от всего подальше :aua:
    И ещё раз - ОГРОМНОЕ СПАСИБО!!!

Поделиться этой страницей