7.7 ограничение прав на просмотр группы

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем snow123, 17 мар 2011.

  1. TopicStarter Overlay
    snow123
    Offline

    snow123

    Регистрация:
    17 мар 2011
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Всем доброго времени суток!
    Помогите новичку разобраться. 7.7, конф Торговля + Склад.
    Необходимо, чтобы пользователь с набором прав "Продавец" не мог при выборе открывать в справочнике контрагентов группу с названием "Поставщики".
    В модуле контрагентов ФормаСписка.ДляВыбора вставил процедуру:

    [Процедура ПриВыбореРодителя(Родитель)

    Если НазваниеНабораПрав()="Продавец" Тогда
    Если Родитель = "Поставщики" Тогда
    Предупреждение ("У Вас нет прав для просмотра этой группы!",2);
    СтатусВозврата(0);
    КонецЕсли;
    КонецЕсли;

    КонецПроцедуры
    ]
    Это не работает. При совпадении обоих условий доступ не закрывается. Точнее, если смотреть через отладчик, то когда пытаемся открыть группу "Поставщики", в отладчике - Родитель = Поставщики, а не Родитель = "Поставщики". Если в коде убрать кавычки у Поставщики, то получим синт.ошибку, тк нет такой переменной. Но ведь это не переменная, а значение. Как правильно это записать? Заранее благодарю за ответ.
  2. Mitay_D
    Offline

    Mitay_D Опытный в 1С

    Регистрация:
    16 фев 2010
    Сообщения:
    314
    Симпатии:
    0
    Баллы:
    26
    Код:
    Родитель.Наименование
    
    
  3. TopicStarter Overlay
    snow123
    Offline

    snow123

    Регистрация:
    17 мар 2011
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    спасибо
  4. Mitay_D
    Offline

    Mitay_D Опытный в 1С

    Регистрация:
    16 фев 2010
    Сообщения:
    314
    Симпатии:
    0
    Баллы:
    26
    было бы за что! мне кнопочки "Спасибо" хватит ))))

Поделиться этой страницей