7.7 Ограничение по времени

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем AlexStuff, 22 май 2013.

  1. TopicStarter Overlay
    AlexStuff
    Offline

    AlexStuff

    Регистрация:
    13 мар 2013
    Сообщения:
    15
    Симпатии:
    0
    Баллы:
    1
    Уважаемые гуру подскажите пожалуйста как ограничить время работы в 1с для пользователей?
    База лежит на сервере. Доступ на сервер не терминальный.
    Задолбали бухи и фины которые уходят и оставляют базу открытой и хрен че сделать можно даже в обед!
    Заранее благодарю всех откликнувшихся!
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Если не открыто модальных окон выгнать можно по обработке ожидания. (послать предупреждение о выгоне тоже)
  3. GlukAl
    Offline

    GlukAl Опытный в 1С

    Регистрация:
    4 окт 2012
    Сообщения:
    187
    Симпатии:
    7
    Баллы:
    29
    можно и при модальных окнах, но нужно подключать внешнюю dll

    Код:
    Процедура ПриНачалеРаботыСистемы()
    ЗагрузитьВнешнююКомпоненту("1CPP.dll");
    глСервис=СоздатьОбъект("Сервис");
    глСервис.ОбработкаОжидания("глПериодическиеСобытияСистемы",60000);
    //ОбработкаОжидания("глПериодическиеСобытияСистемы",60);
    КонецПроцедуры
    
    
    Процедура глПериодическиеСобытияСистемы()
    
    Если ФС.СуществуетФайл(КаталогИБ()+"exiter.ert")=1 Тогда
    ОткрытьФорму("Отчет",,КаталогИБ()+"exiter.ert");
    КонецЕсли;
    КонецПроцедуры
    
    а в открываемой обработке
    текстовка типа "Уважаемые срочно закрываем 1С, у Вас 1 минута"

    Код:
    Процедура ПриПовторномОткрытии()
    ЗакрытьБезПодтверждения=1;
    ЗавершитьРаботуСистемы(0);
    КонецПроцедуры
    для выгона скопировать данную обработку в каталог базы
    после не забыть удалить/переименовать :)
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Можно... Причем vk_KillUsers.dll это делает намного проще чем 1cpp.dll

Поделиться этой страницей