[РЕШЕНО] ограничение количества строк табличной части документа.

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем JediAlex, 20 мар 2015.

  1. TopicStarter Overlay
    JediAlex
    Offline

    JediAlex Опытный в 1С

    Регистрация:
    27 авг 2011
    Сообщения:
    140
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте. Делаю документ в собственной конфигурации на платформе 8.3. Создал документ с табличной частью. По утвержденной руководством форме, табличная часть состоит из 10 строк(изменение состава ТЧ документа возможно только после согласия руководства и утверждения новой формы). ТЧ этого документа заполняю автоматически:
    Код:
    &НаСервере
    Процедура ВыгрузкаКритериев()
    Результат=Справочники.КритерииОценки.Выбрать( ,Объект.Сотрудник);
    Объект.Подразделение=Объект.Сотрудник.Подразделение;
    Объект.Должность=Объект.Сотрудник.Должность;
    Если Объект.КритерииОценки.Количество()=0 Тогда
    Пока Результат.Следующий() Цикл
        НоваяСтрока=Объект.КритерииОценки.Добавить();
            НоваяСтрока.Критерий=Результат.Ссылка;
            НоваяСтрока.НольБаллов=Результат.НольБаллов;
            НоваяСтрока.ОдинБалл=Результат.ОдинБалл;
            НоваяСтрока.ДваБалла=Результат.ДваБалла;
            НоваяСтрока.ТриБалла=Результат.ТриБалла;
            НоваяСтрока.ВесовойКоэффициент=Результат.ВесовойКоэффициент;       
        КонецЦикла;
    КонецЕсли;   
    КонецПроцедуры
    В табличной части есть реквизиты, которые заполняются сотрудником и его руководителем. Вопрос вот в чем: можно ли ограничить количество строк табличной части 10 записями? а то получается иногда ситуация, что пользователь, заполняя 10-ю строку перескакивает ниже и добавляется не нужная 11-я строка...
  2. Thelearning
    Offline

    Thelearning Профессионал в 1С Команда форума

    Регистрация:
    9 сен 2010
    Сообщения:
    701
    Симпатии:
    72
    Баллы:
    54
    Можно. Во-первых необходимо снять флаг "Автоввод новой строки" у табличной части на форме, а также есть событие "ПередНачаломДобавления", в котором можно отказаться от ввода новой строки.
  3. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.566
    Симпатии:
    717
    Баллы:
    204
    при добавлении строки в интерактивном режиме проверять количество строк и не позволять добавлять строку, если количество = 10.
  4. TopicStarter Overlay
    JediAlex
    Offline

    JediAlex Опытный в 1С

    Регистрация:
    27 авг 2011
    Сообщения:
    140
    Симпатии:
    0
    Баллы:
    26
    спасибо,разобрался))

Поделиться этой страницей