7.7 ограничение доступов

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем ИринаСМ, 6 май 2011.

  1. TopicStarter Overlay
    ИринаСМ
    Offline

    ИринаСМ Опытный в 1С

    Регистрация:
    23 апр 2010
    Сообщения:
    158
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте! Помогите, пожалуйста!
    Как в форме "Проводка.ФормаСписка.ДляОпераций" в процедуре "ПриОткрытии" получить счет и субконто для закрытия просмотра проводок документа?
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Штатно - никак.
    Можно "развести бодягу" со справочником пользователей и настройкой прав. Тут вы им кислород перекроете, но через ту же ОСВ - все будет видно.
    Смиритесь с неизбежным
  3. TopicStarter Overlay
    ИринаСМ
    Offline

    ИринаСМ Опытный в 1С

    Регистрация:
    23 апр 2010
    Сообщения:
    158
    Симпатии:
    0
    Баллы:
    26
    у меня есть справочник пользователей, я практически везде перекрыла кислород. осталось вот только в это форме, чтобы она не открывалась. И никак не получается
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    ну вы просто гигант))))))))))

    А если так

    Код:
    Процедура ПриОткрытии()
    Если ВашаПроверкаПрав=0 Тогда
    СтатусВозврата(0);
    Возврат;
    КонецЕсли;
    //то что стандартно
    КонецЕсли;
    
    
  5. TopicStarter Overlay
    ИринаСМ
    Offline

    ИринаСМ Опытный в 1С

    Регистрация:
    23 апр 2010
    Сообщения:
    158
    Симпатии:
    0
    Баллы:
    26
    да уж гигант(

    так не получится, когда из документа открываю проводки, у меня в процедуре при открытии вообще никаких данных об открываемом документе, а мне надо проверить на счет и подразделение. Вот так-то!

    при чем операцию документа мне удалось закрыть по параметрам нужным, а вот проводки никак не получается
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    а вот тут вы ошибаетесь.... причем очень сильно. Это же ОПЕРАЦИЯ! В ней доступны соотвествующие методы и атрибуты.... Следовательно делаем так

    Код:
    Процедура ПриОткрытии()  
    Если Документ.Вид()="НужныйНамВид" Тогда     
    Если ВашаПроверкаПрав()=0 Тогда     
    СтатусВозврата(0);     
    Возврат;  
    КонецЕсли;  
    КонецЕсли;  
    
    //то что стандартно
    КонецПроцедуры
    
    
  7. TopicStarter Overlay
    ИринаСМ
    Offline

    ИринаСМ Опытный в 1С

    Регистрация:
    23 апр 2010
    Сообщения:
    158
    Симпатии:
    0
    Баллы:
    26
    Да, в операции все получается, а вот у меня "Проводка.ФормаСписка.ДляОпераций.Форма", когда я захожу в процедуру ПриОтркытии она вообще мне никаких данных об отркываемом документе не дает. Документ.Вид() тоже.
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Вы имете ввиду так называемый "журнал операций"?
  9. TopicStarter Overlay
    ИринаСМ
    Offline

    ИринаСМ Опытный в 1С

    Регистрация:
    23 апр 2010
    Сообщения:
    158
    Симпатии:
    0
    Баллы:
    26
    Да, журнал операций
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Мммм.... Только заменой на текстовую колонку получится скрыть я думаю
  11. TopicStarter Overlay
    ИринаСМ
    Offline

    ИринаСМ Опытный в 1С

    Регистрация:
    23 апр 2010
    Сообщения:
    158
    Симпатии:
    0
    Баллы:
    26
    Да, все получилось заменой столбца...Спасибо большое!
  12. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Всегда пожалуста. Вот интересно как вы во ВСЕХ отчетах кислород перекрыли... Это же гигантский труд

Поделиться этой страницей