8.х УПП Ограничение доступа пользователя на создание и запись документов только текущим днем.

Тема в разделе ""1С:Управление производственным предприятием УПП"", создана пользователем Sedow, 13 окт 2012.

  1. TopicStarter Overlay
    Sedow
    Offline

    Sedow

    Регистрация:
    26 апр 2012
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    Как настроить Ограничение доступа пользователя на создание и запись документов только текущим днем?
    хотелось бы ограничить работу кладовщика только текущим днем. что бы он мог только создать документ "Перемещение товаров" только текущим днем, что бы не было возможности изменить вчерашние документы.
  2. Наташа
    Offline

    Наташа Опытный в 1С

    Регистрация:
    14 авг 2010
    Сообщения:
    1.442
    Симпатии:
    2
    Баллы:
    29
    Посмотрите, как работает механизм даты запрета изменения данных. Полагаю, можно будет в коде добавить условие: когда пользователь - кладовщик, то дата запрета - конец вчерашнего дня.
  3. ges58
    Offline

    ges58 Опытный в 1С

    Регистрация:
    8 сен 2008
    Сообщения:
    104
    Симпатии:
    0
    Баллы:
    26
    Можно для конкретного пользователя ставить дату запрета изменения - вчерашняя дата, тогда ничего не нужно менять в текстах программ. Сделать это можно обработкой и запускать ее ночью, как реглам.задание. Если пользователей несколько, то создайте группу и добавьте их всех в нее, дату запрета ставьте для группы. Я так месяц закрываю всем группам в нужный день.
  4. Svb
    Offline

    Svb Опытный в 1С Команда форума

    Регистрация:
    12 янв 2011
    Сообщения:
    980
    Симпатии:
    19
    Баллы:
    29
    А можно просто убрать право у пользователя "Интерактивное проведение неоперативное" на нужный документ?
    Тогда если документ проведен вчерашним числом, провести его сегодняшним уже не получится?
  5. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    Вы не путайте интерактивное добавление с режимом проведения документа (оперативный или не оперативный). Интреактивность - это можно же документы создавтаь руками, а можно кодом.
  6. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    Доброго всем,
    решали похожую задачу в УПП,
    (возможно кому то пригодиться)

    + процедура для запуска в регламентном задании
    Код:
    // YuS ->
    // Регламентная процедура для автоматического переноса даты запрета изменений
    // процедура вызывает внешнюю обработку выполняющую основные действия
    Процедура СмещениеДатыЗапретаРедактирования() Экспорт
    ЭлементСправочника = Справочники.ВнешниеОбработки.НайтиПоНаименованию("РегламентСмещениеДатыБлокировки"); // наименование внешней обработки в справочнике
    Если ЭлементСправочника <> Неопределено Тогда
    
    ХранилищеОбработки = ЭлементСправочника.ХранилищеВнешнейОбработки.Получить();
    
    ИмяВременногоФайла = ПолучитьИмяВременногоФайла("epf");
    ВыполнитьДействия = Ложь;
    
    // Сохраним обработку в файл
    Попытка
    ХранилищеОбработки.Записать(ИмяВременногоФайла);
    ВыполнитьДействия = Истина;
    Исключение
    #Если НаКлиенте Тогда
    Сообщить(ОписаниеОшибки(),СтатусСообщения.Важное);
    #КонецЕсли
    #Если НаСервере Тогда
    ЗаписьЖурналаРегистрации("Ошибки смещения, регламент",УровеньЖурналаРегистрации.Предупреждение, , ,ОписаниеОшибки());
    #КонецЕсли
    КонецПопытки;
    
    // Получим объект обработки и выполним процедуры
    Если ВыполнитьДействия Тогда
    
    ВнешняяОбработка = ВнешниеОбработки.Создать(ИмяВременногоФайла,Ложь);
    
    // Выполним процедуру обработки, экспортную !
    ВнешняяОбработка.ВыполнитьОбработку();
    
    // Удалим файл обработки
    Попытка
    УдалитьФайлы(ИмяВременногоФайла);
    Исключение
    #Если НаКлиенте Тогда
    Сообщить(ОписаниеОшибки(),СтатусСообщения.Важное);
    #КонецЕсли
    #Если НаСервере Тогда
    ЗаписьЖурналаРегистрации("Ошибки смещения, регламент",УровеньЖурналаРегистрации.Предупреждение, , ,ОписаниеОшибки());
    #КонецЕсли
    КонецПопытки;
    
    КонецЕсли;
    
    КонецЕсли;
    КонецПроцедуры

    Вложения:

  7. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    ну или вот - правильно сказал человек, через регламентировнное задание по рассписанию. Ну можна соаму процедуру описать в общем модуле, не через обработку. Ну и еще вам там придется проверку на наличе роли делать
  8. Svb
    Offline

    Svb Опытный в 1С Команда форума

    Регистрация:
    12 янв 2011
    Сообщения:
    980
    Симпатии:
    19
    Баллы:
    29
    Все равно не понял.
    Есть право "Интерактивное проведение" и "Интерактивное проведение неоперативное".
    Если оставить только право "Интерактивное проведение", то пользователь же не сможет изменить вчерашний проведенный документ?
  9. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    Как вариант - можно, но при этом надо учитывать что бы эта роль не пересекалась с той, где разрешено это
Похожие темы
  1. kvg
    Ответов:
    2
    Просмотров:
    1.381
  2. Вояжж
    Ответов:
    1
    Просмотров:
    292
  3. Швэрэс
    Ответов:
    1
    Просмотров:
    497
  4. Nik02071
    Ответов:
    3
    Просмотров:
    1.348
  5. AlenkaInt
    Ответов:
    0
    Просмотров:
    753
Загрузка...

Поделиться этой страницей