8.х Оформление табличного поля СКД кодом!?

Тема в разделе "Система компоновки данных (СКД)", создана пользователем web.num, 2 сен 2014.

  1. TriviumFan
    Offline

    TriviumFan Опытный в 1С Заблокирован

    Регистрация:
    19 мар 2013
    Сообщения:
    92
    Симпатии:
    15
    Баллы:
    29
    Та что там копаться, не нужно изобретать велосипед.
    Если зайти в СтандартныеОтчеты.ВывестиОтчет(), то можно обнаружить
    Код:
    Пока Истина Цикл              
                    ОбработкаПрерыванияПользователя();
                    //Получим следующий элемент результата компоновки
                    ЭлементРезультата = ПроцессорКомпоновки.Следующий();              
                    Если ЭлементРезультата = Неопределено Тогда
                        //Следующий элемент не получен - заканчиваем цикл вывода
                        Прервать;
                    Иначе                  
                        Отказ = Ложь;                  
                        Попытка
                            ОтчетОбъект.ПередВыводомЭлементаРезультата(МакетКомпоновки, ДанныеРасшифровки, ЭлементРезультата, Отказ);
                        Исключение
                        КонецПопытки;                  
                        Если Не Отказ Тогда
                            //Элемент получен - выведем его при помощи процессора вывода
                            ПроцессорВывода.ВывестиЭлемент(ЭлементРезультата);
                        КонецЕсли;  
                    КонецЕсли;
                КонецЦикла;
    Ключевая процедура - ПередВыводомЭлементаРезультата(МакетКомпоновки, ДанныеРасшифровки, ЭлементРезультата, Отказ);
  2. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.410
    Симпатии:
    316
    Баллы:
    104
    TriviumFan отлично.. :)
    Теперь покажите процедуру ПередВыводомЭлементаРезультата()
  3. TriviumFan
    Offline

    TriviumFan Опытный в 1С Заблокирован

    Регистрация:
    19 мар 2013
    Сообщения:
    92
    Симпатии:
    15
    Баллы:
    29
    Я всего-лишь предложил вариант -Dead-
    Вот пусть автор создаст и попробует обрабатывать элементы :)

Поделиться этой страницей