Одновременная печать на 2-х принтерах

Тема в разделе "Торговое оборудование в 1С", создана пользователем evgeniy39, 7 сен 2009.

  1. TopicStarter Overlay
    evgeniy39
    Offline

    evgeniy39

    Регистрация:
    7 сен 2009
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Суть проблемы в следующем: Есть 2 зебры TLP2824, необходимо при запуске печати документа, чтобы можно было в модуле прописывать что и на каком принтере печатать, сам фильтр написал
    Код:
    Если ПризнакНаличиеКухня=1 тогда
    если ПустаяСтрока(Принтер2)=0 Тогда
    ИсхТабл.ТолькоПросмотр(0);
    ИсхТабл.ПараметрыСтраницы(,100,,2,0,0,0,,,,,Принтер2);
    ИсхТабл.КоличествоЭкземпляров(1);
    Если ПРЧ=1 Тогда  
    ИсхТабл.Показать(,,);    
    иначе
    ИсхТабл.Показать(,,); 	
    ИсхТабл.Напечатать(0);// Поставили ФР. Выводить на зебру не надо	
    КонецЕсли;
    //Если (ПРЧ1=1) и (СтатусЗак=1) Тогда
    //ИсхТабл.Напечатать(0);    
    //КонецЕсли; 
    конецесли;
    КонецЕсли;
    КонецЕсли;	
    Если ПризнакНаличиеКухня2=1 тогда
    если ПустаяСтрока(Принтер3)=0 Тогда
    ИсхТабл2.ТолькоПросмотр(0);
    ИсхТабл2.ПараметрыСтраницы(,100,,2,0,0,0,,,,,Принтер3);
    ИсхТабл2.КоличествоЭкземпляров(1);
    Если ПРЧ=1 Тогда  
    ИсхТабл2.Показать(,,);    
    иначе
    ИсхТабл.Показать(,,); 	
    ИсхТабл2.Напечатать(0);// Поставили ФР. Выводить на зебру не надо	
    КонецЕсли;
    //Если (ПРЧ1=1) и (СтатусЗак=1) Тогда
    //ИсхТабл.Напечатать(0);    
    //КонецЕсли; 
    конецесли;
    
    Но он все печатает только на один принтер, не могу понять определяет принтер на котором должен печатать, но пускает на другой
  2. tirk
    Offline

    tirk Опытный в 1С

    Регистрация:
    1 сен 2008
    Сообщения:
    1.142
    Симпатии:
    0
    Баллы:
    26
    Метод Напечатать()
    Идет только для принтера по умолчанию....
    Вообще возможно .. в яндексе как то находил...

    Думаю сначало надо определить доступность принтеров в системе а потом явно указывать на них
  3. TopicStarter Overlay
    evgeniy39
    Offline

    evgeniy39

    Регистрация:
    7 сен 2009
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Все проблему решил, принтер по умолчанию тут не причем, я вручную указал принтер

    Принтер2="Zebra24"; //СокрЛП(Строка(глПользователь.ПолучитьАтрибут("Принтер2")));

    и все ОК, всем спасибо, кто участвовал!

Поделиться этой страницей