8.х ОБМЕН Односторонний обмен между УТ 10.3 и БУХ 2.0

Тема в разделе "Обмен данными в "1С:Предприятие 8"", создана пользователем Дима Д, 5 ноя 2013.

  1. TopicStarter Overlay
    Дима Д
    Offline

    Дима Д

    Регистрация:
    5 ноя 2013
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Добрый день подскажите как быть?
    После обновления релизов УТ 10.3 с 10.3.25.1 на 10.3.26.1 и БУХ 2.0 с 2.0.52.6 на 2.0.53.8 обмен данными перестал работать. Обмен односторонний из УТ в БУХ посредством подключения к базе. Правила обмена актуальные проверка проходит нормально. Опишите более подробно решение данной проблемы, так как я в этом слабоват(!

    Ошибка при выгрузке данных для узла плана обмена
    ТипОбъекта = Документ объект: Поступление товаров и услуг
    Объект = Поступление товаров и услуг УТ000001466 от 29.10.2013 18:02:29
    ОписаниеОшибки = Ошибка в обработчике события ПослеВыгрузкиОбъекта
    ПВД = ПоступлениеТоваровУслуг
    Объект = Поступление товаров и услуг УТ000001466 от 29.10.2013 18:02:29 (Документ объект: Поступление товаров и услуг)
    Обработчик = ПослеВыгрузкиОбъектаВыборки
    ОписаниеОшибки = Ошибка в обработчике события ПослеЗагрузкиОбъекта
    ИмяПКО = СчетФактураПолученный
    ТипОбъекта = Счет-фактура полученный
    Объект = Счет-фактура полученный УТ000001671 от 29.10.2013 18:02:29
    Обработчик = ПослеЗагрузкиОбъекта
    ОписаниеОшибки = Ошибка компиляции при вычислении выражения или выполнении фрагмента кода: {(10,34)}: Переменная не определена (Дата)
    ПозицияМодуля = Обработка.ОбменДаннымиXML.МодульОбъекта(7531)
    КодСообщения = 21
    ПозицияМодуля = Обработка.ОбменДаннымиXML.МодульОбъекта(1300)
    КодСообщения = 34
    ПозицияМодуля = Обработка.ОбменДаннымиXML.МодульОбъекта(1668)
    КодСообщения = 72
    УзелПланаОбмена = БП ПожСнабСервис
    Ошибка при загрузке объектов. Было загружено: 43
    Произошла ошибка при выгрузке объектов. Было выгружено: 44

    Техническая информация:
    ОписаниеОшибки = {Обработка.ОбменДаннымиXML.МодульОбъекта(1596)}: Ошибка в обработчике события ПослеЗагрузкиОбъекта
  2. Дринкинс
    Offline

    Дринкинс

    Регистрация:
    3 ноя 2013
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    А какой код ПослеВыгрузки в ПоступленииТоваровУслуг?

    А вообще лучше бы правила в студию
  3. Гриша
    Offline

    Гриша Опытный в 1С

    Регистрация:
    4 май 2008
    Сообщения:
    286
    Симпатии:
    5
    Баллы:
    29
    смотри конвертацию
    Счет фактура "ПослеЗагрузкиОбъекта" там ошибка в синтаксисе !!!
  4. gedd
    Offline

    gedd

    Регистрация:
    14 ноя 2013
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Можно ли поподробнее, где искать? Это в правилах обмена?
  5. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    Обновись на 10.3.26.2
  6. gedd
    Offline

    gedd

    Регистрация:
    14 ноя 2013
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Управление торговлей, редакция 10.3 (10.3.26.2)
    Бухгалтерия предприятия, редакция 2.0 (2.0.53.8)

    вот после обновления это и возникло
  7. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    У тебя в сообщении было 26.1. Пока ничего сказать другого не могу. В понедельник-вторник планирую обновлять клиентов с таким же обменом - там увижу. А конфигурации типовые?
  8. gedd
    Offline

    gedd

    Регистрация:
    14 ноя 2013
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Решение:

    Для исправления нужно в правилах обмена УТ -> БП, в правиле конвертации "СчетФактураПолученный" заменить текст обработчика "После загрузки" на текст ниже.

    Код:
    Если Объект.ЭтоНовый() Тогда
    // это процедура "УстановитьПорядокОтраженияВычетаПоУмолчанию" формы документа "СчетФактураПолученный"
    СчетФактураКомитента = ТипЗнч(Объект.ДокументОснование) = Тип("ДокументСсылка.ОтчетКомитентуОПродажах");
    УпрощенныйУчетНДС = УчетНДС.ПолучитьУПУпрощенныйУчетНДС(Объект.Организация, Объект.Дата);
    СложныйУчетНДС = УчетНДС.ПолучитьУПСложныйУчетНДС(Объект.Организация, Объект.Дата);
    Если СчетФактураКомитента Тогда
    Объект.НДСПредъявленКВычету = Ложь;
    ИначеЕсли УпрощенныйУчетНДС ИЛИ Объект.Дата >= '20120101' Тогда
    Если Объект.ВидСчетаФактуры = Перечисления.ВидСчетаФактурыПолученного.НаПоступление
    И НЕ Объект.Исправление Тогда
    Объект.НДСПредъявленКВычету = НЕ СложныйУчетНДС;
    ИначеЕсли Объект.ВидСчетаФактуры = Перечисления.ВидСчетаФактурыПолученного.НаАванс Тогда
    Объект.НДСПредъявленКВычету = НЕ УпрощенныйУчетНДС;
    Иначе
    Объект.НДСПредъявленКВычету = Ложь;
    КонецЕсли;
    Иначе
    Объект.НДСПредъявленКВычету = Ложь;
    КонецЕсли;
    КонецЕсли;
    Готовые поправленные правила обмена Управление торговлей, редакция 10.3 (10.3.26.2) -> Бухгалтерия предприятия, редакция 2.0 (2.0.53.8)
  9. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    Откуда инфа?
  10. gedd
    Offline

    gedd

    Регистрация:
    14 ноя 2013
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    1С, может правила не обновились просто ...
  11. Гриша
    Offline

    Гриша Опытный в 1С

    Регистрация:
    4 май 2008
    Сообщения:
    286
    Симпатии:
    5
    Баллы:
    29
    дело в том чтобы при обновлении УТ нужно запустить обработку которая правила обмена обновляет
    обычно она сама запускается
    не помню как называется как то так "выполнить регл операции после обновлении" или что то похожее
  12. gedd
    Offline

    gedd

    Регистрация:
    14 ноя 2013
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    проблема признана 1С, решение у них же, обработка "Обновление информационной базы" должна была стартовать автоматом, правила у меня были последние, последний раз она делает переход с версии 10.3.25, проверьте сами
  13. prince
    Offline

    prince

    Регистрация:
    15 ноя 2013
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    все верно, действительно, сейчас человек позвонил с такой проблемой решилось заменой "Дата" на "Объект.Дата". Спасибо gedd )

Поделиться этой страницей