8.х УТ Один документ не проводится по партиям

Тема в разделе ""1С:Управление торговлей УТ"", создана пользователем Itsys, 23 ноя 2010.

  1. TopicStarter Overlay
    Itsys
    Offline

    Itsys Опытный в 1С

    Регистрация:
    3 янв 2010
    Сообщения:
    1.394
    Симпатии:
    0
    Баллы:
    26
    Добрый день,

    Такой глюк, один документ не формирует партии при проведении, в настройках формирование при проведении, залез в отладчик,
    Код:
        // Проводить по партиям нужно при передаче со склада
    Если ВидПередачи = Перечисления.ВидыПередачиТоваров.СоСклада Тогда
    
    // Проводить по партиям сразу нужно если установлен параметр
    // учетной политики СписыватьПартииПриПроведенииДокументов
    ПроводитьПоПартиям = РегистрыСведений.УчетнаяПолитика.ПолучитьПоследнее(Дата).СписыватьПартииПриПроведенииДокументов;
    Если ПроводитьПоПартиям Тогда
    
    УправлениеЗапасамиПартионныйУчет.ДвижениеПартийТоваров(Ссылка, Движения.СписанныеТовары.Выгрузить());
    
    Иначе
    
    // В неоперативном режиме границы последовательностей сдвигаются назад, если они позже документа.
    Если РежимПроведения = РежимПроведенияДокумента.Неоперативный Тогда
    УправлениеЗапасамиПартионныйУчет.СдвигГраницыПоследовательностиПартионногоУчетаНазад(Дата, Ссылка, Организация);
    КонецЕсли;
    
    КонецЕсли;
    КонецЕсли;
    
    
    Доходит до строки
    Код:
                УправлениеЗапасамиПартионныйУчет.ДвижениеПартийТоваров(Ссылка, Движения.СписанныеТовары.Выгрузить());
    
    
    И даже не входит в процедуру, а сразу идет в конец условия. С чем может быть связан глюк?
    В остальных документах все нормально.
    В Движения.СписанныеТовары.Выгрузить() 2 строки.
    База SQL
  2. tirk
    Offline

    tirk Опытный в 1С

    Регистрация:
    1 сен 2008
    Сообщения:
    1.142
    Симпатии:
    0
    Баллы:
    26
    насколько я помню..
    УправлениеЗапасамиПартионныйУчет - это модуль выполняется на стороне сервера.. именно поэтому вы туда не зайдете



    сделайте копию файловой и работайте
    или устанвоите признак клиент..
  3. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    ... либо в службе сервера 1С надо добавить ключ -debug...
  4. TopicStarter Overlay
    Itsys
    Offline

    Itsys Опытный в 1С

    Регистрация:
    3 янв 2010
    Сообщения:
    1.394
    Симпатии:
    0
    Баллы:
    26
    Не получилось у меня отладить на сервере, и ключ добавил, и предмет отладки "Сервер" подключил и точку останова в процедуре поставил. Не входит. Плюнул, поставил галку Клиент и понял, что проблема не в этом.
    Продолжение следует http://www.1c-pro.ru/index.php?showtopic=27894

Поделиться этой страницей