7.7 Очистить периодические значения

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем Ontojko, 16 апр 2010.

  1. TopicStarter Overlay
    Ontojko
    Offline

    Ontojko

    Регистрация:
    16 апр 2010
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Код:
    Процедура Очистить()
    Спр = СоздатьОбъект("Справочник.Номенклатура");
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент() = 1 Цикл
    ТекЭл = Спр.ТекущийЭлемент();
    ПерРек = СоздатьОбъект("Периодический");
    ПерРек.ИспользоватьОбъект(,ТекЭл);
    // или Вариант 2
    //ПерРек.ИспользоватьОбъект("Реквизит",ТекЭл);
    ПерРек.ВыбратьЗначения();
    Пока ПерРек.ПолучитьЗначение() = 1 Цикл
    ПерРек.Удалить();
    КонецЦикла;
    КонецЦикла;
    КонецПроцедуры
    
    При этом выдает "Перед выполнением операции (непосредственно удаление) нужно вызвать 'ИспользоватьОбъект'!"
    При втором "ОбщееКолВо не является константой или периодическим параметром!" по строке ИспользоватьОбъект... Ну он периодический естественно.

    HELP
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Код:
    ....
    Пока Спр.ПолучитьЭлемент() = 1 Цикл
    Если Спр.ЭтоГруппа()=1 Тогда
    Продолжить;
    КонецЕсли;
    ТекЭл = Спр.ТекущийЭлемент();
    ....
    
    
  3. TopicStarter Overlay
    Ontojko
    Offline

    Ontojko

    Регистрация:
    16 апр 2010
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    мда... o_O

    Совсем забыл.. Спасибо.

Поделиться этой страницей