7.7 Обратиться к процедуре из другого модуля

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Samouchka, 26 май 2014.

  1. TopicStarter Overlay
    Samouchka
    Offline

    Samouchka Опытный в 1С

    Регистрация:
    20 мар 2013
    Сообщения:
    214
    Симпатии:
    1
    Баллы:
    29
    Всем привет! Есть документ, в котором я создал процедуру, чтобы сразу без предварительного просмотра его напечатать. Процедуру ПечатьСразу() сделал экспортной. Теперь в обработке хочу обращаться к ней по ссылкам на документы (есть колонка, содержащая ссылки на документы, которые надо распечатать). Выходит ошибка: "Поле агрегатного объекта не обнаружено (ПечатьСразу)". Думаю, что я в своем коде до самого документа как объекта не добираюсь. Методов как в 1с 8 "ПолучитьСсылку", "ПолучитьОбъект" похоже не хватает. Вот код из модуля формы документа:
    Код:
    Процедура ПечатьСразу() экспорт
        Если СтарДог=0 Тогда
        Таб = СоздатьОбъект("Таблица");
        Таб.ИсходнаяТаблица("Таблица");
        Таб.ВывестиСекцию("Печатать");
        Таб.Напечатать(0);   
        КонецЕсли;
        Если СтарДог=1 Тогда
        Таб = СоздатьОбъект("Таблица");
        Таб.ИсходнаяТаблица("Старый договор");
        Таб.ВывестиСекцию("Печатать");
        Таб.Напечатать(0);
        КонецЕсли;
    КонецПроцедуры
    А это код из модуля обработки:
    Процедура АвтДоговорПеч()
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
    АвтоуслугиДоговор.ПечатьСразу();
    АвтоуслугиДоговорДо01012012.ПечатьСразу();
    КонецЦикла
    КонецПроцедуры
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    В 7ке НЕЛЬЗЯ напрямую обратиться к процедурам модуля.
    Можно через
    1) Компоненту FormEx
    2) Настраивать механизм печати через параметры формы и вызывать процедуру печать в процедуре ПриОткрытии

Поделиться этой страницей