[РЕШЕНО] Обратиться к модулю обработки из модуля формы

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Flash-Dance, 16 мар 2014.

  1. TopicStarter Overlay
    Flash-Dance
    Offline

    Flash-Dance Профессионал в 1С

    Регистрация:
    20 май 2012
    Сообщения:
    365
    Симпатии:
    42
    Баллы:
    54
    Всем привет. Есть внешняя Обработка. Содержит Форму и Макет
    Процедуры и функции по управлению Макетом прописываются в общем модуле этой Обработки.
    Как получить доступ к этим процедурам и функциям из модуля Формы этой обработки?
  2. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.991
    Симпатии:
    399
    Баллы:
    104
    Не в общем модуле, а в модуле объекта этой обработки. Из формы можно обращаться к процедурам и функциям, которые прописаны в модуле объекта с ключевым словом экспорт. Пример:
    Код:
    Процедура МояПроцедура() Экспорт
    Но только при условии, что данные формы ссылаются на ОбработкаОбъект.
  3. TopicStarter Overlay
    Flash-Dance
    Offline

    Flash-Dance Профессионал в 1С

    Регистрация:
    20 май 2012
    Сообщения:
    365
    Симпатии:
    42
    Баллы:
    54
    "Экспорт" написал. Но при сохранении выдает, что процедура или функция неопределена. Как к ним обратиться?
  4. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.991
    Симпатии:
    399
    Баллы:
    104
    Киньте Вашу обработку сюда, я посмотрю.
    --- Объединение сообщений, 16 мар 2014 ---
    Либо это смотрите.
  5. TopicStarter Overlay
    Flash-Dance
    Offline

    Flash-Dance Профессионал в 1С

    Регистрация:
    20 май 2012
    Сообщения:
    365
    Симпатии:
    42
    Баллы:
    54
    Упростил обработку, чтобы лишний код с элементами глаза не мозолили.

    Вложения:

    Последнее редактирование: 16 мар 2014
  6. TopicStarter Overlay
    Flash-Dance
    Offline

    Flash-Dance Профессионал в 1С

    Регистрация:
    20 май 2012
    Сообщения:
    365
    Симпатии:
    42
    Баллы:
    54
    Каким образом они должны ссылаться?
  7. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.991
    Симпатии:
    399
    Баллы:
    104
    Это для обычного приложения. В управляемом немного по-другому все.
    В Вашей обработке пропишите этот код
    Код:
    &НаСервере
    Функция ЦенникиНаСервере(МассивНоменклатура,МассивШтрихкод,МассивЦена);
    
        ОбъектВЗначении = РеквизитФормыВЗначение("Объект");
        МакетЦенников = ОбъектВЗначении.Ценники(МассивНоменклатура,МассивШтрихкод,МассивЦена);
        Возврат МакетЦенников;
    
    КонецФункции
    
    &НаКлиенте
    Процедура ПечатьЦенников(Команда)
    
        МассивНоменклатура = Новый Массив;
        МассивШтрихкод = Новый Массив;
        МассивЦена = Новый Массив;
        Для Каждого Строка из Объект.ТаблицаПеремещениеТоваров Цикл
            Если Строка[Объект.ВыборРаспределения] Тогда
                Для Количество = 1 по Строка[Объект.ВыборРаспределения] Цикл
                    МассивНоменклатура.Добавить(ПолучитьРеквизитНоменклатуры(Строка.Номенклатура,"Наименование"));
                    МассивШтрихкод.Добавить(НайтиПоследнийШтрихкодНоменклатуры(Строка.Номенклатура));
                    МассивЦена.Добавить(НайтиЦенуНоменклатуры(Строка.Номенклатура,ПолучитьДанныеСклада(Объект.СкладПолучатель,"РозничныйВидЦены")));
                КонецЦикла;
            КонецЕсли;
        КонецЦикла;
        ЦенникиНаСервере(МассивНоменклатура,МассивШтрихкод,МассивЦена).Показать();
    
    КонецПроцедуры
    
    Flash-Dance нравится это.
  8. TopicStarter Overlay
    Flash-Dance
    Offline

    Flash-Dance Профессионал в 1С

    Регистрация:
    20 май 2012
    Сообщения:
    365
    Симпатии:
    42
    Баллы:
    54
    Код:
    ОбъектВЗначении = РеквизитФормыВЗначение("Объект");
    Вот это мне и нужно было узнать! Спасибо!

Поделиться этой страницей