8.х ? обратиться к группе справочника...

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Smeha69, 10 май 2008.

  1. TopicStarter Overlay
    Smeha69
    Offline

    Smeha69

    Регистрация:
    19 июл 2007
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Ребят..я тут вы..бся!
    Хочу обратиться к группе товаров...
    Так как каждая группа как и элемент справочника имеет свой код, то решил обращаться по коду
    например у нас Сыр и Мясо в группе "Продукты" с кодом 00043, Степлер и Скотч в группе "Канцелярские"
    и если мы в ТабличнойЧасти выбираем группу Продукты, тогда система должна к примеру сообщить "!!!"
    Код:
    Процедура ТоварыТоварПриИзменении(Элемент)
    
    СтрокаТабличнойЧасти=ЭлементыФормы.Товары.ТекущиеДанные;                                                                                                                             
    ИскомаяСсылка=Элементыформы.Товары.Текущиеданные;                                                                  
    Если Справочники.Номенклатура.НайтиПоНаименованию(ИскомаяССылка.Товар).код=00043  
    Тогда   Сообщить("!!!");
    Конецесли;    
    КонецПроцедуры
    
    Табличная часть у меня Товары,
    в строке табличной части всего одно поле "Товар"-СправочникСсылка.Номенклатура


    но не пашет!! :unsure:
  2. Stack_G
    Offline

    Stack_G Опытный в 1С

    Регистрация:
    10 дек 2007
    Сообщения:
    786
    Симпатии:
    2
    Баллы:
    26
    Посмотрите, скорее всего "код" - строковый.

    Вот так можно получить наименование группы, например. Может вам поможет.
    Код:
    Группа = Справочники.Номенклатура.НайтиПоКоду("00043");
    Сообщить(Группа.Наименование);
    
  3. TopicStarter Overlay
    Smeha69
    Offline

    Smeha69

    Регистрация:
    19 июл 2007
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    именно так! Код строковый...
  4. TopicStarter Overlay
    Smeha69
    Offline

    Smeha69

    Регистрация:
    19 июл 2007
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    [kod]
    Группа1 = Справочники.Номенклатура.НайтиПоКоду("00043");
    Группа2 = Справочники.Номенклатура.НайтиПоКоду("00017");
    Для каждого СтрокаТабличнойЧасти из Товары
    Цикл
    Если СтрокаТабличнойЧасти.Товар=Группа1 Тогда Сообщить("Гусеничные трактора")

    ИначеЕсли СтрокаТабличнойЧасти.Товар=Группа2 Тогда Сообщить("Колесные трактора");

    КонецЕсли;
    КонецЦикла;
    [/kod]
    вот так заработало!!
  5. AlexFF
    Offline

    AlexFF Разбирающийся

    Регистрация:
    6 мар 2007
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    26
    Код:
    Для Каждого Строчка из Товары Цикл
    Сообщить(Строчка.Номенклатура.Родитель.Код + "  " + Строчка.Номенклатура.Родитель.Наименование);
    // сюда же впихиваем какие необходимо проверки.    
    КонецЦикла; 
    
    

Поделиться этой страницей