8.х Обратиться из внешней обработки к элементам формы

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Мариночка, 5 ноя 2015.

  1. TopicStarter Overlay
    Мариночка
    Offline

    Мариночка

    Регистрация:
    24 фев 2014
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    1с 8.1. Есть внешняя обработка для макета печати. Я создала на форме документы Табличное поле с типом ТаблицаЗначений "СтоимостьУслуг", там заполняются данные при нажатии на кнопку. Мне нужно эти данные вывести на макет печати внешней обработки. На макете я создала отдельную область и параметры. Но не могу никак получить эти данные. Подскажите, что не так..
    Код:
    Форма =Документы.ТТН.ПолучитьФорму("ФормаДокумента");
         мСтоимостьУслуг = Форма.ЭлементыФормы.СтоимостьУслуг.Значение;
    Обл = Макет.ПолучитьОбласть("Усл");   
    
     Для каждого стр из мСтоимостьУслуг Цикл
    
    обл.Параметры.Услуга1=стр.Услуга;
    обл.Параметры.Стоимость1 = стр.Стоимость;
    
    ТабДокумент.Вывести(Обл);
    
    КонецЦикла;
    
    

    Вложения:

    • ирс.jpg
      ирс.jpg
      Размер файла:
      101,8 КБ
      Просмотров:
      9
  2. IceBeerG
    Offline

    IceBeerG Опытный в 1С

    Регистрация:
    15 дек 2012
    Сообщения:
    193
    Симпатии:
    11
    Баллы:
    29
    А вариант хранения данных в объекте, а не на форме не подходит?
  3. Ktyf
    Offline

    Ktyf Опытный в 1С

    Регистрация:
    16 янв 2013
    Сообщения:
    457
    Симпатии:
    12
    Баллы:
    29
    смущает ".Значение" что вы получаете в результате в мСтоимостьУслуг?
  4. Mahail
    Offline

    Mahail Новичок в 1С

    Регистрация:
    25 окт 2015
    Сообщения:
    34
    Симпатии:
    1
    Баллы:
    4
    Попробуйте вместо "Форма =Документы.ТТН.ПолучитьФорму("ФормаДокумента");" вставить "Форма =СсылкаНаОбъект.ПолучитьФорму("ФормаДокумента"); Если Форма.Открыта() Тогда мСтоимостьУслуг = Форма.ЭлементыФормы.СтоимостьУслуг.Значение; КонецЕсли", где СсылкаНа!Объект - реквизит внешней обработки, хранящий ссылку на документ, из формы которого нужно взять данные.
  5. antares
    Offline

    antares Опытный в 1С

    Регистрация:
    30 ноя 2006
    Сообщения:
    340
    Симпатии:
    7
    Баллы:
    29
    2 Мариночка
    вам нужна форма текущего объекта документа, а не форма объекта метаданных; ниже пример обращения к данным ТП формы, с открытием макета думаю у вас проблем нет; важно, чтобы ТП было связано с реквизитом формы (!! а не документа) - ТЗ
    Код:
    &НаКлиенте
    Процедура ПечатьУслуг(Команда)
        // Вставить содержимое обработчика.
        для каждого стр из ЭтаФорма.СтоимостьУслуг цикл
            Сообщить(стр.Услуга);
        КонецЦикла;
    КонецПроцедуры
    
    на директивы компилятора не обращайте внимания, у меня пример в упр.приложении
    Последнее редактирование: 8 ноя 2015

Поделиться этой страницей