8.х Обращние из 1С 8.1 к базе на Firebird 1.5

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Gfdtk, 13 окт 2009.

  1. TopicStarter Overlay
    Gfdtk
    Offline

    Gfdtk Опытный в 1С

    Регистрация:
    28 апр 2008
    Сообщения:
    158
    Симпатии:
    0
    Баллы:
    26
    В базе Firebird есть данные которые периодически нужно скидывать в 1С. Это можно решить при помощи V8.Application или СОМ-соединения и если да то как.

    Если есть какие ресурсы по этой теме скиньте ссылок.
  2. lazy
    Offline

    lazy Модераторы Команда форума Модератор

    Регистрация:
    1 сен 2007
    Сообщения:
    2.127
    Симпатии:
    4
    Баллы:
    29
    Да, можно. Вот пример из рабочей обработки тянущей данные из базы огнептицы:
    Код:
     
    Процедура ПриОткрытии()
    Соединение = Новый COMОбъект("ADODB.Connection");
    
    Соединение.ConnectionString = "DSN=FireBird;Driver={Firebird/InterBase® driver};Dialect=3; Dbname=" +
    СокрЛП("localhost") + ":" + 
    СокрЛП("C:�baseP�basep.FDB") + ";CHARSET=NONE;Uid=" +
    СокрЛП("SYSDBA") + ";Pwd=" + 
    СокрЛП("masterkey") + ";Client=gds32.dll";
    // gfix -sql_dialect 3
    Соединение.ConnectionTimeout = 60;
    Соединение.CursorLocation = 3;
    
    Попытка
    Соединение.Open();
    Исключение
    Сообщить(ОписаниеОшибки());
    КонецПопытки;
    
    КонецПроцедуры 
    
    
    Процедура СотрудникиВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)
    ТекстЗапроса = "
    |SELECT AREAS_TREE.DISPLAY_NAME, a.ID_TB_IN, a.STAFF_ID, a.DATE_PASS, a.TIME_PASS, a.TYPE_PASS, a.CONFIG_TREE_ID, a.AREAS_TREE_ID, a.PARTICIPATES_CALC, a.VIRTUAL_EVENTS
    |FROM TABEL_INTERMEDIADATE a
    |LEFT JOIN AREAS_TREE on a.AREAS_TREE_ID = AREAS_TREE.ID_AREAS_TREE         
    |where STAFF_ID = "+Формат(ЭлементыФормы.Сотрудники.ТекущиеДанные.ID_STAFF,"ЧГ=0");
    
    
    Попытка
    // Выборка данных и перебор результата запроса 
    ВыборкаСтрокС = Соединение.Execute(ТекстЗапроса); 
    Исключение
    Сообщить(ОписаниеОшибки());
    Возврат;
    КонецПопытки;    
    
    График.Очистить();
    Пока ВыборкаСтрокС.EOF=0 Цикл //Цикл по записям 
    стр =  График.Добавить();
    стр.Дата = ВыборкаСтрокС.Fields("DATE_PASS").value;
    
    ВыборкаСтрокС.MoveNext(); //Переходим к след. записи
    КонецЦикла;
    
    КонецПроцедуры 
    
    
    Если поищете, в сети есть и другие примеры работы с firebird.
  3. fasttaker
    Offline

    fasttaker

    Регистрация:
    11 дек 2008
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    А можно ли средствами 1с записывать в Firebird?
  4. lazy
    Offline

    lazy Модераторы Команда форума Модератор

    Регистрация:
    1 сен 2007
    Сообщения:
    2.127
    Симпатии:
    4
    Баллы:
    29
    Разумеется можно. Необходимо
    Код:
    ТекстЗапроса =  "SELECT AREAS_TREE.DISPLAY_NAME, a.ID_TB_IN, a.STAFF_ID..."
    
    
    Поменять с SELECT запроса на INSERT или UPDATE запрос - более подробно, как запросами записывать данные в базу читайте в руководствах по языку запросов SQL.
    Например вот тут есть статьи на эту тему:
    http://ru.wikipedia.org/wiki/Insert_%28SQL%29
    http://ru.wikipedia.org/wiki/UPDATE
    http://ru.wikipedia.org/wiki/Delete_%28SQL%29

    Т.е. составляете необходимый запрос - делаете ему
    Код:
    .Execute(ТекстЗапроса)
    
    и вуаля...
  5. dmsh1234
    Offline

    dmsh1234

    Регистрация:
    15 апр 2011
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Уважаемый lazy,

    подскажите что нужно для подключения к базе FireBird из 1С
    может, я не очень правильно сформулировал, но есть СКУД и просят сделать перегрузку в 1С
    СКУД работает на FB и я посмотрел сообщения на эту тему, все касается нюансов выборки, а что надо чтобы хотябы подключится из 1с к базе

    с уважением
  6. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    А чем не подходит код во втором сообщении этой темы?
Похожие темы
  1. AGOR
    Ответов:
    1
    Просмотров:
    1.000
  2. sagitt
    Ответов:
    24
    Просмотров:
    1.358
  3. VDL
    Ответов:
    5
    Просмотров:
    469
Загрузка...

Поделиться этой страницей