7.7 Обращение к реквизиту ТЧ

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем sashadeo, 10 июл 2013.

  1. TopicStarter Overlay
    sashadeo
    Offline

    sashadeo Опытный в 1С

    Регистрация:
    29 дек 2010
    Сообщения:
    379
    Симпатии:
    0
    Баллы:
    26
    Добрый день!
    Подскажите как обратиться к реквизиту тч который является ссылкой на справочник.
    Ниже часть кода подскажите что не так)

    Код:
     Спр = СоздатьОбъект ("Справочник.ВидыНачисленийИПрочихДоходов");
    Документ = СоздатьОбъект("Документ");
    Документ.УстановитьФильтр(1, 0);
    Документ.ВыбратьПодчиненныеДокументы(,, ТекущийДокумент());
    Пока Документ.ПолучитьДокумент() = 1 Цикл
    //Спр.НайтиПоНаименованию("Документ.НачислениеПрочийДоход",0,1);
    Документ.НачислениеПрочийДоход = Спр.ТекущийЭлемент();
    //Если   Документ.Сотрудник = Сотрудник Тогда
    //Если Документ.Вид() <> "ДополнительныеНачисления" Тогда
    // Продолжить;
    //КонецЕсли;
    Сообщить(Документ.НомерДок);
    Сообщить(Документ.ДатаДок);
    Сообщить(Документ.Сотрудник);
    Сообщить(Документ.НачислениеПрочийДоход);
    Сообщить(Документ.Итог("Сумма"));
    //КонецЕсли;
    КонецЦикла;
  2. Herby
    Offline

    Herby Опытный в 1С

    Регистрация:
    21 фев 2013
    Сообщения:
    95
    Симпатии:
    0
    Баллы:
    26
    вы обратиться хотите для записи или для чтения?

    ну в любом случае, нужен еще один цикл для обхода ТЧ:

    Код:
    Документ.ВыбратьСтроки();
    Пока Документ.ПолучитьСтроку() = 1 Цикл
    КонецЦикла;
    
  3. TopicStarter Overlay
    sashadeo
    Offline

    sashadeo Опытный в 1С

    Регистрация:
    29 дек 2010
    Сообщения:
    379
    Симпатии:
    0
    Баллы:
    26
    Обратиться хочу для записи.
    Спасибо! Добавил Цикл все заработало)

Поделиться этой страницей