8.х Обращение к перечислению

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем prog_22, 24 ноя 2013.

  1. TopicStarter Overlay
    prog_22
    Offline

    prog_22 Опытный в 1С

    Регистрация:
    31 окт 2012
    Сообщения:
    171
    Симпатии:
    0
    Баллы:
    26
    Добрый вечер!

    Есть справочник. В справочнике табличная часть "Статусы". В ней реквизит "Статус" с ссылкой на ПеречислениеСсылка.СтатусыЗадач1С

    Так вот задача:

    Когда значение статуса "выполнено" тогда необходимо сообщить конкретному пользователю что она закрыта. в Формате Сообщить(Задача (наименование элемента справочника) выполнена!)

    Пишу код:

    Код:
     &НаСервере
    Процедура ПередЗаписьюНаСервере()
    Если перечисления.СтатусыЗадач1с.Выполнено= Истина
    Тогда Сообщить("Задача выполнена!")
    КонецЕсли;
    КонецПроцедуры
    
    Ошибок нет, но сообщения нет.

    Ут 10.3, в толстом клиенте но формы управляемые

    Что не так?
  2. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.979
    Симпатии:
    397
    Баллы:
    104
    Ну так вы и сравнивайте нужное значение с перечислением. Т.е. как то так
    Код:
    Если Ваш Реквизит = Перечисления.СтатусыЗадач1с.Выполнено Тогда
    //
    КонецЕсли;
  3. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    посмотрите в синтаксис помощнике "ПредопределенноеЗначение"

    Код не сработает, потому как разные типы.
    посмотрите в СП также "Перечисление", "Перечисления", "ПеречислениеМенеджер"
  4. TopicStarter Overlay
    prog_22
    Offline

    prog_22 Опытный в 1С

    Регистрация:
    31 окт 2012
    Сообщения:
    171
    Симпатии:
    0
    Баллы:
    26
    Со сравнением разобрался, работает. но нужно сообщить не текущему пользователю, а конкретному. Этот вариант с помощью регл.заданий делается, или есть попроще варианты?
  5. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.979
    Симпатии:
    397
    Баллы:
    104
    Оповещение пользователей к сожалению не реализовано в 1с. Придется самому дописывать сеё.
  6. TopicStarter Overlay
    prog_22
    Offline

    prog_22 Опытный в 1С

    Регистрация:
    31 окт 2012
    Сообщения:
    171
    Симпатии:
    0
    Баллы:
    26
    Вот например путь: я создаю регл.задание- в процедуре пишу выборку из справочника, устанавливаю параметр на определенного пользователя- далее условие на совпадение реквизита и перечисления?
  7. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.979
    Симпатии:
    397
    Баллы:
    104
    Что это? Я не понимаю. Если Вам нужно оповещение пользователей. То это делается следующим образом. Не нужно использовать регламентное задание. Нужно ПодключитьОбработчикОжидания. Создать регистр сведений. Где будут храниться сообщения для конкретного пользователя. Создать обоработку. Которая будет настраивать этот регистр и выдавать окошко для пользователя. И все будет хорошо. По сути все.
  8. TopicStarter Overlay
    prog_22
    Offline

    prog_22 Опытный в 1С

    Регистрация:
    31 окт 2012
    Сообщения:
    171
    Симпатии:
    0
    Баллы:
    26
    Спасибо!Буду пробовать
Похожие темы
  1. Panchess
    Ответов:
    2
    Просмотров:
    537
  2. hust
    Ответов:
    9
    Просмотров:
    722
Загрузка...

Поделиться этой страницей