8.х обраотка расшифровки отчета на СКД

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем UnNone, 17 июн 2011.

  1. TopicStarter Overlay
    UnNone
    Offline

    UnNone Опытный в 1С

    Регистрация:
    21 мар 2007
    Сообщения:
    148
    Симпатии:
    0
    Баллы:
    26
    Есть отчет написанный на СКД. Данные выводятся так:
    Таблица:
    ___Строки
    ______Поле1
    ________Поле2
    __________Поле3
    ____Колонки
    ______Поле4

    Появилась необходимость написать свою расшифровку для табличной части.
    В расшифровке суммы участвую все значения Поле1 - Поле4.
    В обработчике расшифровке с помошью функций ПолучитьРодителей() и ПолучитьПоля(), удалось получить значения полей 3 и 4 для конкретной суммы:
    Код:
    Поле3 = ДанныеРасшифровки.Элементы[Расшифровка].ПолучитьРодителей()[0].ПолучитьПоля()[0].значение;
    Поле4 = ДанныеРасшифровки.Элементы[Расшифровка].ПолучитьРодителей()[1].ПолучитьПоля()[0].значение;
    
    Как получить значение полей 1 и 2?
  2. Wladimir89
    Offline

    Wladimir89

    Регистрация:
    3 июн 2011
    Сообщения:
    48
    Симпатии:
    0
    Баллы:
    1

    Решил задачу?
    У самого подобная проблема
  3. TimonChD
    Offline

    TimonChD

    Регистрация:
    17 июл 2007
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    Вот мой образец. Находить всех родителей.
    Код:
     
    Родитель = ДанныеРасшифровки.Элементы[Расшифровка];
    Пока Истина Цикл
    МассивРодителей = Родитель.ПолучитьРодителей();
    Если МассивРодителей.Количество() = 0 Тогда
    Прервать;
    КонецЕсли;
    Родитель = Родитель.ПолучитьРодителей()[0];
    Если ТипЗнч(Родитель) = Тип("ЭлементРасшифровкиКомпоновкиДанныхПоля") Тогда
    Поле = Родитель.ПолучитьПоля()[0].Значение;
    НовыйЭлементОтбора = НастройкиР.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    ПолеОтбора = Новый ПолеКомпоновкиДанных(Родитель.ПолучитьПоля()[0].Поле);			
    НовыйЭлементОтбора.ЛевоеЗначение  = ПолеОтбора;
    НовыйЭлементОтбора.Использование  = Истина;
    НовыйЭлементОтбора.ВидСравнения   = ВидСравненияКомпоновкиДанных.Равно;
    НовыйЭлементОтбора.ПравоеЗначение = Поле;
    КонецЕсли;
    КонецЦикла;	
    
    
Похожие темы
  1. Alive
    Ответов:
    3
    Просмотров:
    846
Загрузка...

Поделиться этой страницей