8.х ОбработкаВыбора не происходит

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем ЕкатеринаНик, 12 май 2016.

  1. TopicStarter Overlay
    ЕкатеринаНик
    Offline

    ЕкатеринаНик Опытный в 1С

    Регистрация:
    8 ноя 2010
    Сообщения:
    698
    Симпатии:
    1
    Баллы:
    29
    Здравствуйте!

    пытаюсь из самописного документа в ЗУП открыть обработку ФормированиеСпискаСотрудников. В документе в табличной части Задания есть реквизит Сотрудник.
    Формируется список аналогично документу ОтпускаОрганизаций, оттуда взято
    Код:
    Код:
    Процедура ДействияФормыЗаполнить(Кнопка)
    ...
    ПроцедурыУправленияПерсоналом.ОткрытьФормуОтбораСпискаРаботников(ЭтаФорма, Дата, , Организация,Подразделение);
    КонецПроцедуры
    в модуле формы
    Код:
    Код:
    Процедура ОбработкаВыбора(ЗначениеВыбора, Источник)
    
    Если ТипЗнч(ЗначениеВыбора) = Тип("Структура") Тогда
    Команда = "";
    Если ЗначениеВыбора.Свойство("Команда",Команда) и Команда = "ЗаполнитьСписокРаботников" Тогда
    Задания.Загрузить(ЗначениеВыбора.Данные.Выгрузить())
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры
    В обработкуВыбора вообще не попадает(((
    Почему?
  2. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.948
    Симпатии:
    149
    Баллы:
    104
    Надо посмотреть в процедуре "ПроцедурыУправленияПерсоналом.ОткрытьФормуОтбораСпискаРаботников()" код, который открывает форму: посмотреть, какой владелец устанавливается в открываемую форму. Ведь событие "ОбработкаВыбора" срабатывает у владельца. Поэтому, чтобы это событие сработало у текущей формы, надо передать эту форму в качестве владельца в открываемую форму обработки.
  3. TopicStarter Overlay
    ЕкатеринаНик
    Offline

    ЕкатеринаНик Опытный в 1С

    Регистрация:
    8 ноя 2010
    Сообщения:
    698
    Симпатии:
    1
    Баллы:
    29
    ОбработкуВыбора на форму не нацепила((( От того она и не срабатывала(((

Поделиться этой страницей