8.х УТ ОбработкаПроведения

Тема в разделе ""1С:Управление торговлей УТ"", создана пользователем Fura, 10 сен 2011.

  1. TopicStarter Overlay
    Fura
    Offline

    Fura

    Регистрация:
    30 авг 2011
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Помогите пожалуйста.. Необходимо чтобы при заполнении окна "Оплачено", число отнималась от общей суммы, а сейчас отнимается от каждого наименования товара отдельно... Что нужно сделать не понимаю... Код:
    Если ПродажаВРассрочку Тогда


    Если СуммаДокумента <> 0 Тогда
    Движения.ПродажаВРассрочку.Записывать = Истина;
    Движение = Движения.ПродажаВРассрочку.Добавить();
    Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
    Движение.Период = Дата;
    Движение.Покупатель = Контрагент;
    Движение.СуммаДолга = СуммаДокумента;
    КонецЕсли;


    Если Оплачено <> 0 Тогда
    Движения.ПродажаВРассрочку.Записывать = Истина;
    Движение = Движения.ПродажаВРассрочку.Добавить();
    Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
    Движение.Период = Дата;
    Движение.Покупатель = Контрагент;
    Движение.СуммаДолга = Оплачено;
    КонецЕсли;

    КонецЕсли;
Похожие темы
  1. Захарова
    Ответов:
    5
    Просмотров:
    2.209
Загрузка...

Поделиться этой страницей