8.х Обработка заполнения табличной части документа.Помогите!

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем НатальяНат, 20 сен 2012.

  1. TopicStarter Overlay
    НатальяНат
    Offline

    НатальяНат

    Регистрация:
    20 сен 2012
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте!
    Необходимо создать внешнюю обработку заполнения табличной части "Товары" документа "Отчет о розничных продажах".
    В модуле обработки написала процедуру :

    Код:
    Процедура Инициализировать(Объект, ИмяТабличнойЧасти = Неопределено, ТабличноеПолеОбъекта = Неопределено) Экспорт
    
    Для каждого СтрТабличнойЧасти Из Документы.ОтчетОРозничныхПродажах Цикл
    НоваяСтрока = СсылкаНаОбъект.Товары.Добавить();
    НоваяСтрока.Номенклатура = СсылкаНаОбъект.Товары.Получить().Номенклатура;
    НоваяСтрока.Упаковка = СсылкаНаОбъект.Товары.Получить().Упаковка;
    НоваяСтрока.КоличествоУпаковокУчет = СсылкаНаОбъект.Товары.Получить().КоличествоУпаковокУчет;
    НоваяСтрока.КоличествоУпаковокФакт = 0;
    НоваяСтрока.КоличествоУпаковок = СсылкаНаОбъект.Товары.Получить().КоличествоУпаковок;
    
    Если СсылкаНаОбъект.Товары.Получить().Цена = Неопределено или СсылкаНаОбъект.Товары.Получить().Цена.Пустая() Тогда
    НоваяСтрока.Цена = 0.01;
    КонецЕсли;
    НоваяСтрока.Сумма = СсылкаНаОбъект.Товары.Получить().Сумма;
    НоваяСтрока.СтавкаНДС = Перечисления.СтавкиНДС.БезНДС;
    НоваяСтрока.СуммаНДС = СсылкаНаОбъект.Товары.Получить().СуммаНДС;
    КонецЦикла;
    Форма=ПолучитьФорму("Форма");
    Форма.ОткрытьМодально(); 
    КонецПроцедуры
    
    Вот.. и на форме обработки кнопку сделала и в форме написала такое:


    Код:
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    Инициализировать(Документы.ОтчетОРозничныхПродажах.ПолучитьФорму(), "Товары", "");
    КонецПроцедуры
    и ничего не работает что то.. никак не могу понять как обработку делать нормально.((((((( помогите пожалуйста!
  2. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    может я чего не понимаю, но по мне - вот эта строка это бред....
    Код:
    Для каждого СтрТабличнойЧасти Из Документы.ОтчетОРозничныхПродажах Цикл
    судя по итератору, вы пытаетесь обратиться к строкам табличной части документа, а Документы.ОтчетОРозничныхПродажах - это ведь не табличная часть.....

    укажите откуда берете данные о заполнении табчасти дока

    что есть СсылкаНаОбект?
  3. Мистер Смит
    Offline

    Мистер Смит Опытный в 1С

    Регистрация:
    29 фев 2012
    Сообщения:
    69
    Симпатии:
    0
    Баллы:
    26
    Странный код, какими данными вы собираетесь заполнять тч товары?
  4. TopicStarter Overlay
    НатальяНат
    Offline

    НатальяНат

    Регистрация:
    20 сен 2012
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Еще раз Здравствуйте! не скажите как тему удалить? Проблема решена!=))))

Поделиться этой страницей