8.х Обработка XML файла

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем cobra77777, 5 июн 2014.

  1. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте!
    Есть файл XML след.структуры (привожу в сокращённой форме):
    Задача вывести в ТЗ показать колонки: Страх.Номер, Фамилия, Имя, Отчество, ДатаНачалаПериода, ДатаКонцаПериода.
    Затем все это Экспортировать в Excell (c полями показанные выше).
    Есть код и несколько вопросов:
    1. Как показать в ТЗ поля;
    2. Как вывести в XLS.

    Процедура КнопкаВыполнитьНажатие(Кнопка)
    Попытка
    ЧтениеXML = Новый ЧтениеXML;
    ЧтениеXML.ОткрытьФайл(ПутьКФайлу);
    Пока ЧтениеXML.Прочитать() Цикл
    Если ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
    Имя = ЧтениеXML.Имя;
    КонецЕсли;
    Если Имя = "СтраховойНомер" и ЧтениеXML.ТипУзла = ТипУзлаXML.Текст Тогда
    Сообщить(ЧтениеXML.Значение);
    КонецЕсли;
    Если Имя = "Фамилия" и ЧтениеXML.ТипУзла = ТипУзлаXML.Текст Тогда
    Сообщить(ЧтениеXML.Значение);
    КонецЕсли;
    Если Имя = "Имя" и ЧтениеXML.ТипУзла = ТипУзлаXML.Текст Тогда
    Сообщить(ЧтениеXML.Значение);
    КонецЕсли;
    Если Имя = "Отчество" и ЧтениеXML.ТипУзла = ТипУзлаXML.Текст Тогда
    Сообщить(ЧтениеXML.Значение);
    КонецЕсли;
    КонецЦикла;
    ЧтениеXML.Закрыть();
    Исключение
    Сообщить(ОписаниеОшибки());
    КонецПопытки;
    КонецПроцедуры


    ФАЙЛ ИМЕЕТ СЛЕД.СТРУКТУРУ:

    <Год>2010</Год>
    </ОтчетныйПериод>
    <СтраховойНомер>123-111-222 33</СтраховойНомер>
    <ФИО>
    <Фамилия>Иванов</Фамилия>
    <Имя>Иван</Имя>
    <Отчество>Иванович</Отчество>
    </ФИО>
    <НомерСтроки>1</НомерСтроки>
    <ДатаНачалаПериода>01.01.2010</ДатаНачалаПериода>
    <ДатаКонцаПериода>31.12.2010</ДатаКонцаПериода>

Поделиться этой страницей