8.х Обработка внешнего события

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем GRUV, 16 май 2008.

  1. TopicStarter Overlay
    GRUV
    Offline

    GRUV Опытный в 1С

    Регистрация:
    7 ноя 2007
    Сообщения:
    106
    Симпатии:
    0
    Баллы:
    26
    Вопрос наверное простой: как в обработчике внешнего события в форме сделать так, чтобы внешнее событие не обрабатывалось в модуле приложения.
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Никак. Этот системное событие.
  3. TopicStarter Overlay
    GRUV
    Offline

    GRUV Опытный в 1С

    Регистрация:
    7 ноя 2007
    Сообщения:
    106
    Симпатии:
    0
    Баллы:
    26
    Жаль что средствами 1С этого нельзя сделать, я вот выкрутился так:

    МОДУЛЬ ПРИЛОЖЕНИЯ:

    Код:
    Перем ОбработкаВнешнегоСобытияВМодулеПриложения				Экспорт;
    
    Процедура ОбработкаВнешнегоСобытия(Источник, Событие, Данные)
    
    Если Не ОбработкаВнешнегоСобытияВМодулеПриложения Тогда
    ОбработкаВнешнегоСобытияВМодулеПриложения = Истина;
    Возврат
    КонецЕсли;
    
    //Код
    
    КонецПроцедуры
    
    МОДУЛЬ ФОРМЫ:

    Код:
    Процедура ВнешнееСобытие(Источник, Событие, Данные)	
    
    ОбработкаВнешнегоСобытияВМодулеПриложения = Ложь;
    
    //Код
    
    КонецПроцедуры
    
    
  4. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Хм.... А что первое вызывается?
  5. TopicStarter Overlay
    GRUV
    Offline

    GRUV Опытный в 1С

    Регистрация:
    7 ноя 2007
    Сообщения:
    106
    Симпатии:
    0
    Баллы:
    26
    Сначало внешнее событие обрабатывается в открытых формах

Поделиться этой страницей