7.7 Обработка Счет-Фактура

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем lsd, 20 окт 2009.

  1. TopicStarter Overlay
    lsd
    Offline

    lsd

    Регистрация:
    30 июл 2009
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Подскажите пожалуйста проблема такая . Нужна обработка чтобы пробежала по все счетам-фактурам и проставила в табличной части ставку 18% . :unsure: (для бухгалтерии 7.7)
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Поэтому-то у тебя и с книгой были проблемы.....
    Вот процедура которая тебе поможет....

    Код:
    Док=СоздатьОбъект("Документ.СчетФактура");
    Док.ВыбратьДокументы(НачДата,КонДата);
    Пока Док.ПолучитьДокумент()=1 Цикл
    Док.ВыбратьСтроки();
    ПокаДок.ПолучитьСтроку()=1 Цикл
    Если ТипЗначения(Док.Товар)<>11 Тогда
    продолжить;
    КонецЕсли;
    Док.Счет=СчетПоКоду("90.3");
    Док.НазначитьТип("Субконто1","Справочник.ВидыНоменклатуры");
    Док.Субконто1=Док.Товар.ВидНоменклатуры;
    Док.НазначитьТип("Субконто2","Справочник.СтавкиНДС");
    Док.Субконто2=Док.Товар.СтавкаНДС.Получить(Док.ДатаДок);
    КонецЦикла;
    Док.Записать();
    КонецЦикла;
    
    
  3. TopicStarter Overlay
    lsd
    Offline

    lsd

    Регистрация:
    30 июл 2009
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Да именно поэтому НДС и попадал в не облагаемый:) Спасибо за обработочку . Только она чето не хочет проставлять в табличной части Ставку НДС 18 % :( Я так понял обработка заполняет вкладку Корр.счет и номер ГТД . У меня только не заполнено поле во вкладке Табличная часть СтавкаНДС . Может я чето не так делаю . :unsure:
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Тогда нужно:
    Код:
    Док.СтавкаНДС=Док.Товар.СтавкаНДС.Получить(Док.ДатаДок);    
    
    
  5. TopicStarter Overlay
    lsd
    Offline

    lsd

    Регистрация:
    30 июл 2009
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Спасибо . Все отлично справились:))) Обработка работает :unsure:

Поделиться этой страницей