7.7 обработка подбора

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем crysalis, 21 мар 2013.

  1. TopicStarter Overlay
    crysalis
    Offline

    crysalis

    Регистрация:
    26 мар 2012
    Сообщения:
    38
    Симпатии:
    0
    Баллы:
    1
    есть справочник "номенклатура"
    есть подчиненый ему справочник - "комплектующие"

    в форме "комплектующих", сделал кнопку "подбор", чтобы вызывалась форма "номенклатуры" через "открытьподбор"

    Там все нормально, данные заносятся в ТЗ и ТЗ передается в основную форму "комплектующих".
    Проблема встала в том, что я не соображу как мне создать\добавить эти данные, полученные через подбор, в справочник "комплектующие".

    создаю справочник по новой, создаю новый элемент и начинаю заполнять, но вот, зараза она такая, ругаться начинает:(
    ткните меня носом в чем косяк:(

    код обработки подбора:

    Код:
    Процедура ОбработкаПодбора(параметр321)
    ТекВладелец = ИспользоватьВладельца();
    ТипЗнач  = ТипЗначенияСтр(параметр321);
    Если ТипЗнач = "ТаблицаЗначений" тогда
    
    Комплектующие1 = СоздатьОбъект("Справочник.Комплектация");
    Комплектующие1.ИспользоватьВладельца(ТекВладелец);
    //Комплектующие1.ВыбратьЭлементы();
    врспр=создатьобъект("Справочник.Номенклатура");
    Параметр321.выбратьстроки();
    Пока Параметр321.Получитьстроку()=1 Цикл
    врспр.найтипореквизиту("Артикул",Параметр321.Артикул,1);
    Комплектующие1.новый();
    Комплектующие1.наименование=врспр.Наименование;
    Комплектующие1.владелец=врспр.владелец;
    Комплектующие1.родитель=врспр.родитель;
    Комплектующие1.номенклатура=врспр.Наименование;
    Комплектующие1.количество=Параметр321.количество;
    Комплектующие1.ценовойКоэфф=0;
    
    //Комплектующие1.записать();
    КонецЦикла;
    Форма.Обновить(1);
    КонецЕсли;
    
    
    КонецПроцедуры // ОбработкаПодбора()

    выскакивает ошибка
    Комплектующие1.владелец=врспр.владелец;
    справочник.Комплектация.ФормаСписка.ФормаСписка.Модуль(31): Неверный тип вышестоящего справочника!

    Как так вообще возможно, если типы данных одинаковые :aua:



    ЗЫ
    только у меня одно выскакиывает окошко подобное при заходе на форуме?

    [​IMG]
  2. TopicStarter Overlay
    crysalis
    Offline

    crysalis

    Регистрация:
    26 мар 2012
    Сообщения:
    38
    Симпатии:
    0
    Баллы:
    1
    отбой... сам разобрался :yahoo:
    мозг просто перестает под вечер работать :D

Поделиться этой страницей