8.х Обработка "ОтражениеЗарплатыВРеглУчете"

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Z-bob, 3 мар 2014.

  1. TopicStarter Overlay
    Z-bob
    Offline

    Z-bob Опытный в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте, есть документ "ОтражениеЗарплатыВРеглУчете", там есть ТЧ "ОтражениеВУчете".
    Надо сделать обработку с циклом, чтобы из этой ТЧ выбирал один реквизит "СчетКТ" и менял его значение на другое...
    Помогите с кодом...
    Вот с чего начал:

    Код:
    выбрать1 = документы.ОтражениеЗарплатыВРеглУчете.Выбрать(Дата1, КонецДня(Дата2));
        Пока выбрать1.Следующий() Цикл
    ...
    КонецЦикла;
    вот и все)
    Последнее редактирование модератором: 3 мар 2014
  2. TopicStarter Overlay
    Z-bob
    Offline

    Z-bob Опытный в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    Все решил проблему:

    Код:
    выбрать1 = документы.ОтражениеЗарплатыВРеглУчете.Выбрать(Дата1, КонецДня(Дата2));
    Я32 = ПланыСчетов.Типовой.НайтиПоКоду("Я32");
    Я3220 = ПланыСчетов.Типовой.НайтиПоКоду("3220");
      Пока выбрать1.Следующий() Цикл
    Док = выбрать1.ПолучитьОбъект();
    Для Каждого СтрТЧ ИЗ Док.ОтражениеВУчете Цикл
      Если СтрТЧ.СчетКТ = Я32 Тогда
    СтрТЧ.СчетКТ = Я3220;
    //...здесь реквизиты субконто изменяются...
      КонецЕсли;
    КонецЦикла;
      Док.Записать(РежимЗаписиДокумента.Запись);
      Док.Записать(РежимЗаписиДокумента.Проведение, РежимПроведенияДокумента.Неоперативный);
    КонецЦикла;
    Последнее редактирование модератором: 3 мар 2014

Поделиться этой страницей