7.7 обработка.отчет по кассирам?

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем Дмитрий Маренин, 3 дек 2009.

  1. TopicStarter Overlay
    Дмитрий Маренин
    Offline

    Дмитрий Маренин Опытный в 1С

    Регистрация:
    24 ноя 2009
    Сообщения:
    104
    Симпатии:
    0
    Баллы:
    26
    не могу найти ошибку!!
    Код:
    Процедура СформироватьТаблицуПродаж()
    Расшифровка = СоздатьОбъект("СписокЗначений");
    Расшифровка.Установить("Продавец", Продавец);
    Если Продавец.Выбран() = 0 Тогда
    Предупреждение("Не выбран продавец!",60);
    возврат;
    иначе
    ТаблицаПродаж = СоздатьОбъект("ТаблицаЗначений");
    ТаблицаПродаж.НоваяКолонка("ДатаДок", "Дата", , , "Дата", 15);
    ТаблицаПродаж.НоваяКолонка("Номер", "Строка", 20, , "Номер", 15);
    ТаблицаПродаж.НоваяКолонка("Сумма", "Число", 18, 2, "Сумма", 20);
    ТаблицаПродаж.НоваяКолонка("Продавец", "Справочник.Контрагенты", , ,
    "Продавец", 30);
    Док = СоздатьОбъект("Документ");
    Док.ВыбратьДокументы(НачДата, КонДата);
    Пока Док.ПолучитьДокумент() = 1 Цикл 
    Если Док.Вид() = "ЧекККМ" Тогда
    Если Док.Проведен() = 1 Тогда  
    ТаблицаПродаж.Продавец = Док.Продавец;
    если Док.Продавец = Продавец   тогда 
    ТаблицаПродаж.ДатаДок = Док.ДатаДок;
    ТаблицаПродаж.Номер = Док.НомерДок;
    ТаблицаПродаж.Сумма = Док.Итог("Сумма"); 
    иначе
    Предупреждение("Нет продаж!",60);
    возврат;
    конецЕсли;
    КонецЕсли;
    КонецЕсли;
    КонецЦикла;
    КонецЕсли; 
    //   ТаблицаПродаж.ВыбратьСтроку();
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Продажи");
    Таб.ВывестиСекцию("Шапка");
    ТаблицаПродаж.ВыбратьСтроки();
    Пока ТаблицаПродаж.ПолучитьСтроку() = 1 Цикл
    Таб.ВывестиСекцию("Строка");
    КонецЦикла;
    Таб.Показать();
    КонецПроцедуры
    //*******************************************
    Процедура Сформировать() 
    СформироватьТаблицуПродаж();
    КонецПроцедуры
    
    
    [warn=Внимание!]
    Пользуемся тегами!
    [/warn]
  2. TopicStarter Overlay
    Дмитрий Маренин
    Offline

    Дмитрий Маренин Опытный в 1С

    Регистрация:
    24 ноя 2009
    Сообщения:
    104
    Симпатии:
    0
    Баллы:
    26
    дело в том что обработка не высчитывает, выдает нет продаж
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Забыли добавить строку
    Код:
    ...
    ТаблицаПродаж.НоваяСтрока();
    ТаблицаПродаж.Продавец = Док.Продавец;
    ...
    
    
  4. TopicStarter Overlay
    Дмитрий Маренин
    Offline

    Дмитрий Маренин Опытный в 1С

    Регистрация:
    24 ноя 2009
    Сообщения:
    104
    Симпатии:
    0
    Баллы:
    26
    тоже самое
    нет продаж :unsure:
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Код:
    Пока Док.ПолучитьДокумент() = 1 Цикл           
    Если Док.Вид() = "ЧекККМ" Тогда              
    Если Док.Проведен() = 1 Тогда                 
    ТаблицаПродаж.НоваяСтрока();
    ТаблицаПродаж.Продавец = Док.Продавец;               
    ТаблицаПродаж.ДатаДок = Док.ДатаДок;         
    ТаблицаПродаж.Номер = Док.НомерДок;         
    ТаблицаПродаж.Сумма = Док.Итог("Сумма"); 
    КонецЕсли;
    КонецЕсли;
    КонецЦикла;      
    ТаблицаПродаж.Сортировать("Продавец");
    
    
    
    Если нужно фильтровать по выбранному реквизиту, то так

    Код:
    Пока Док.ПолучитьДокумент() = 1 Цикл           
    Если Док.Вид() = "ЧекККМ" Тогда              
    Если Док.Проведен() = 1 Тогда                 
    Если Док.Продавец<>Продавец Тогда
    продолжить; 
    КонецЕсли; 
    ТаблицаПродаж.НоваяСтрока();
    ТаблицаПродаж.Продавец = Док.Продавец;               
    ТаблицаПродаж.ДатаДок = Док.ДатаДок;         
    ТаблицаПродаж.Номер = Док.НомерДок;         
    ТаблицаПродаж.Сумма = Док.Итог("Сумма"); 
    КонецЕсли;
    КонецЕсли;
    КонецЦикла;      
    
    
    
    
  6. TopicStarter Overlay
    Дмитрий Маренин
    Offline

    Дмитрий Маренин Опытный в 1С

    Регистрация:
    24 ноя 2009
    Сообщения:
    104
    Симпатии:
    0
    Баллы:
    26
    что то с превым кодом не пошло, второй вро де пока работает
    СПАСИБО

Поделиться этой страницей