8.х Обработка общей команды

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем skv_79, 22 апр 2014.

  1. TopicStarter Overlay
    skv_79
    Offline

    skv_79 Опытный в 1С

    Регистрация:
    10 июл 2013
    Сообщения:
    206
    Симпатии:
    3
    Баллы:
    29
    Здравствуйте!
    Создал общую команду и указал в каких документах она должна присутствовать. Если вызываю отладку из конфигуратора, то она без проблем отрабатывает, а если в режиме предприятие, то нет. Попробовал подключиться отладчиком к приложению, сразу запущенному в режиме предприятие и обнаружил, что ПараметрКоманды передается по разному. Через конфигуратор возможно обращение ПараметрКоманды.Автор, а через предприятие нет. Не могу понять почему так.
    Код:
    &НаКлиенте
    Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
       АвторДокумента = ПараметрКоманды.Автор;
       Если ПараметрКоманды.Автор="" Тогда
         АвторДокумента="Автор неизвестен";
       КонецЕсли;
       Сообщить ("Автор и время создания текущего документа: "+АвторДокумента+", "+ПараметрКоманды.ВремяСозданияАвтором)   
    КонецПроцедуры
    
    --- Объединение сообщений, 22 апр 2014 ---
    Попробовал сделать так:
    Код:
    &НаКлиентеНаСервере
    Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
        ДокОбъект = ПараметрКоманды.ПолучитьОбъект();
        АвторДокумента = ДокОбъект.Автор;
        Если ПараметрКоманды.Автор="" Тогда
            АвторДокумента="Автор неизвестен";
        КонецЕсли;
        Сообщить ("Автор и время создания текущего документа: "+АвторДокумента+", "+ДокОбъект.ВремяСозданияАвтором)   
    КонецПроцедуры
    
    Возникает ошибка Метод объекта не обнаружен (ПолучитьОбъект)
    Последнее редактирование: 22 апр 2014
  2. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    А в параметрах самой команды указали ссылку на объект конфигурации ? Вернее тип параметра команды ?
    И желательно в отдельную серверную процедуру выносите получение и обработку объекта.
  3. TopicStarter Overlay
    skv_79
    Offline

    skv_79 Опытный в 1С

    Регистрация:
    10 июл 2013
    Сообщения:
    206
    Симпатии:
    3
    Баллы:
    29
    Да, в свойствах команды указал составной тип данных нескольких документов. Просто не пойму, почему в разных режимах команда отрабатывает по разному.
  4. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Говорю же, попробуйте обработать в отдельной процедуре с директивой НаСервере, а не на КлинетеИСервере.
    skv_79 нравится это.
  5. TopicStarter Overlay
    skv_79
    Offline

    skv_79 Опытный в 1С

    Регистрация:
    10 июл 2013
    Сообщения:
    206
    Симпатии:
    3
    Баллы:
    29
    Решил проблему переносом в общий модуль. Все получилось, спасибо!

Поделиться этой страницей