7.7 Обработка нового реквизита в справочнике

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Natalia_k, 11 сен 2009.

  1. TopicStarter Overlay
    Natalia_k
    Offline

    Natalia_k Опытный в 1С

    Регистрация:
    8 сен 2009
    Сообщения:
    153
    Симпатии:
    0
    Баллы:
    26
    Добрый день!
    Подскажите кто-нибудь, пожалуйста!
    Я создала новый реквизит ЛистСогл (Номер листа согласия) в Конфигурации Справочники->Контрагенты
    Нарисовала на форме поле для ввода номера листа согласия.

    Проблема в том, что номер заносится вручную, сохраняется, но если импортировать этот номер из таблицы DBF или наоборот выгружать из базы этот номер, то колонка выгрузки пустая.
    Подскажите, пожалуйста, в чем проблема? Что нужно прописать для этого реквизита в модуле данной формы с полем для ввода листа согласия, чтобы из этого поля можно было бы выгружать номер и загружать номер в это поле?

    Я сделала еще проверку на совпадение номеров, но она почему-то не работает, хотя в случае проверки паспортных данных, эта проверка работает:

    Код:
    //************** ПРОВЕРКА НА СОВПАДЕНИЕ НОМЕРОВ ЛИСТА СОГЛАСИЯ *********************************************     
    
    функция ПроверкаЛистаСогл()
    Перем рез1;
    рез1=1;
    если (СокрЛП(ЛистСогл)="") тогда
    возврат рез1;
    конецесли;
    
    Контр = СоздатьОбъект("Справочник.Контрагенты");
    ТЗ = СоздатьОбъект("ТаблицаЗначений");
    ТЗ.НоваяКолонка("Двойник","Справочник.Контрагенты");
    Контр.ВыбратьЭлементыПоРеквизиту("ЛистСогл",ЛистСогл,0,0);
    ТекстСообщения = "";
    Пока Контр.ПолучитьЭлемент() = 1 Цикл
    Если (Контр.ЛистСогл = ЛистСогл) Тогда  
    если Контр.Код=Код тогда
    Продолжить;
    конецесли;
    ТекстСообщения = ТекстСообщения+"Такой номер листа согласия "+ЛистСогл+" уже есть в базе "+Контр.Код+""+РазделительСтрок; 
    ТЗ.НоваяСтрока();
    ТЗ.Двойник = Контр.ТекущийЭлемент();
    КонецЕсли;
    КонецЦикла;
    Если ПустоеЗначение(ТекстСообщения) = 0 Тогда
    //Сообщить(ТекстСообщения);
    Если Вопрос("Совпадение реквизитов номеров листа согласия."+РазделительСтрок+"Показать двойников?","Да+Нет")  = "Да" Тогда
    ОткрытьФорму("Отчет.Двойники",ТЗ);
    рез1=0;
    СтатусВозврата(0);
    КонецЕсли; 
    КонецЕсли;
    
    возврат рез1;
    конецфункции
    //******************************************************************************
    
    

    ПОДСКАЖИТЕ, ПОЖАЛУЙСТА
  2. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    Реквизит нужно добавить в сам справочник.
    у реквизита должна стоять галка сортировка

Поделиться этой страницей