8.х Обработка кодов в справочниках

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем 9IHy6, 14 фев 2008.

  1. TopicStarter Overlay
    9IHy6
    Offline

    9IHy6

    Регистрация:
    11 фев 2008
    Сообщения:
    31
    Симпатии:
    0
    Баллы:
    1
    Уважаемые прошу Вашей помосчи!
    Не буду говорить про свой уровень программиста.. и так сё понятно!
    Задача в следующем: Необходимо подправить коды в справочниках (таких как Номенклатура, Контрагенты..) стоит Торговля 10.3.2.11 и Бухгалтерия 1.6. Нужно это естественно для выгрузки.
    Сразу хочу оговориться:"Штатные выгрузки не совсем правильно заработали".
    в торговле коды меньше фактически, в конфигураторе идентичны Бухгалтерии! мало того у этих спров, в торговле, префиксы. Т.е. необходимо вставить в середину кода пару нулей..
    В семерке помню была обработка.. в восмерке к сожалению не нашел..
    Может ктонить подскажет какую либо обработку!? (Обработка подбора и замены значений в спрах и доках не обрабатывают кодов :()
    Да..пытался написать собственную .. не сильно получаетцо Еси подскажите в чем ошибка тож буду благодарен!!!!

    Код:
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    
    Выборка = Справочники.Номенклатура.Выбрать();
    Пока Выборка.Следующий() Цикл
    Номен = Выборка.ПолучитьОбъект();
    ДлинаКода = СтрДлина(СокрЛП(Номен.Код));
    Наим = Номен.Наименование; //почемуто нету!, а код подхватывает..
    Если ДлинаКода < 11 Тогда //в условие не попадает т.к. ДлинаКода = 11
    //хотя, опять таки, в Торговле символов = 9
    Префикс = Лев(Номен.Код,3);
    Хвост = Прав(Номен.Код,6);
    Номен.Код = Префикс + "00" + Хвост;
    КонецЕсли;
    Номен.Записать();    
    КонецЦикла;
    
    // Вставить содержимое обработчика.
    КонецПроцедуры
    
    
    Со своей стороны я понимаю, что задача не сложная, НО сроки вчера НННеlp.
  2. TopicStarter Overlay
    9IHy6
    Offline

    9IHy6

    Регистрация:
    11 фев 2008
    Сообщения:
    31
    Симпатии:
    0
    Баллы:
    1
    :unsure: Спасибо всем! я разобралсо сам!

Поделиться этой страницей